summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.8.1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-03-19 21:11:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:01 +0100
commitf6cb2449074d510ce8256f9bcdb9a9e081f2cb53 (patch)
treef20f8ff02c8b3c17daa498cf7364af40f01eaebb /meta/recipes-support/lz4/lz4_1.8.1.2.bb
parent71826b40f273106b0d26cf20e426519906015c75 (diff)
downloadpoky-f6cb2449074d510ce8256f9bcdb9a9e081f2cb53.tar.gz
lz4: upgrade 1.7.4 -> 1.8.1.2
0001-tests-Makefile-don-t-use-LIBDIR-as-variable.patch accepted upstream. License-Update: rephrased clarification regarding lib/ vs. programs/, tests/ and examples/ https://github.com/lz4/lz4/commit/97df1c9789cbc8a7891cadbd49ea5053574e2f72 (From OE-Core rev: 633a2ac95b72c685031aa6c76943c2fb073e1921) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.8.1.2.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.8.1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.8.1.2.bb b/meta/recipes-support/lz4/lz4_1.8.1.2.bb
new file mode 100644
index 0000000000..03017b3ff7
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.8.1.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3
4LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
5LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
6 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
8 "
9
10PE = "1"
11
12SRCREV = "dfed9fa1d77f0434306d377c4da1f7191d3ba08a"
13
14SRC_URI = "git://github.com/lz4/lz4.git \
15 file://run-ptest \
16 "
17UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
22
23do_install() {
24 oe_runmake install
25}
26
27BBCLASSEXTEND = "native nativesdk"