summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.29.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-04 14:35:08 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:16 +0000
commitc38e700644583b0833e8a9831a7dda3678a7d041 (patch)
treeb356aa39a47c15d8dca7e71d450dc8893a2d852f /meta/recipes-support/libxslt/libxslt_1.1.29.bb
parentc37b0922db0741cb6e84febc64e99268fdb50502 (diff)
downloadpoky-c38e700644583b0833e8a9831a7dda3678a7d041.tar.gz
libxslt: update to 1.1.31
Drop upstreamed patches, including pkg-config support patch, as upstream now does use pkg-config. configure.in is now configure.ac, adjust recipe accordingly. (From OE-Core rev: e9d487de8b5c03108c8c25c0365d5bd6b48f03e9) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.29.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.29.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.29.bb b/meta/recipes-support/libxslt/libxslt_1.1.29.bb
deleted file mode 100644
index d27c706602..0000000000
--- a/meta/recipes-support/libxslt/libxslt_1.1.29.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
13 file://0001-Use-pkg-config-to-find-gcrypt-and-libxml2.patch \
14 file://0001-Link-libraries-with-libm.patch \
15 file://0001-Check-for-integer-overflow-in-xsltAddTextString.patch \
16 "
17
18SRC_URI[md5sum] = "a129d3c44c022de3b9dcf6d6f288d72e"
19SRC_URI[sha256sum] = "b5976e3857837e7617b29f2249ebb5eeac34e249208d31f1fbf7a6ba7a4090ce"
20
21UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
22
23S = "${WORKDIR}/libxslt-${PV}"
24
25BINCONFIG = "${bindir}/xslt-config"
26
27inherit autotools pkgconfig binconfig-disabled lib_package
28
29# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
30do_configure_prepend () {
31 sed -i -e 's/ansidecl.h//' ${S}/configure.in
32
33 # The timestamps in the 1.1.28 tarball are messed up causing this file to
34 # appear out of date. Touch it so that we don't try to regenerate it.
35 touch ${S}/doc/xsltproc.1
36}
37
38EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
39# older versions of this recipe had ${PN}-utils
40RPROVIDES_${PN}-bin += "${PN}-utils"
41RCONFLICTS_${PN}-bin += "${PN}-utils"
42RREPLACES_${PN}-bin += "${PN}-utils"
43
44
45do_install_append_class-native () {
46 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
47}
48
49FILES_${PN} += "${libdir}/libxslt-plugins"
50FILES_${PN}-dev += "${libdir}/xsltConf.sh"
51
52BBCLASSEXTEND = "native nativesdk"