summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.29.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:14:59 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-04 14:13:35 +0100
commit9b937870cbe5dfaddb5a5b8e3405c9c03936667f (patch)
treebefca0d5be521b6a26b3ce8a23a3d7ddf3de9c33 /meta/recipes-support/libxslt/libxslt_1.1.29.bb
parenteddd0ec9eeecae8af0266784132c0207cf1b9924 (diff)
downloadpoky-9b937870cbe5dfaddb5a5b8e3405c9c03936667f.tar.gz
libxslt: update to 1.1.29
Drop upstreamed CVE-2015-7995.patch Rebase pkgconfig.patch (From OE-Core rev: f83217590d3157c1db502ddb27b94fe1c704185b) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.29.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.29.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.29.bb b/meta/recipes-support/libxslt/libxslt_1.1.29.bb
new file mode 100644
index 0000000000..be747e608d
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.29.bb
@@ -0,0 +1,50 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
13 file://0001-Use-pkg-config-to-find-gcrypt-and-libxml2.patch \
14 "
15
16SRC_URI[md5sum] = "a129d3c44c022de3b9dcf6d6f288d72e"
17SRC_URI[sha256sum] = "b5976e3857837e7617b29f2249ebb5eeac34e249208d31f1fbf7a6ba7a4090ce"
18
19UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
20
21S = "${WORKDIR}/libxslt-${PV}"
22
23BINCONFIG = "${bindir}/xslt-config"
24
25inherit autotools pkgconfig binconfig-disabled lib_package
26
27# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
28do_configure_prepend () {
29 sed -i -e 's/ansidecl.h//' ${S}/configure.in
30
31 # The timestamps in the 1.1.28 tarball are messed up causing this file to
32 # appear out of date. Touch it so that we don't try to regenerate it.
33 touch ${S}/doc/xsltproc.1
34}
35
36EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
37# older versions of this recipe had ${PN}-utils
38RPROVIDES_${PN}-bin += "${PN}-utils"
39RCONFLICTS_${PN}-bin += "${PN}-utils"
40RREPLACES_${PN}-bin += "${PN}-utils"
41
42
43do_install_append_class-native () {
44 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
45}
46
47FILES_${PN} += "${libdir}/libxslt-plugins"
48FILES_${PN}-dev += "${libdir}/xsltConf.sh"
49
50BBCLASSEXTEND = "native nativesdk"