summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.28.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-support/libxslt/libxslt_1.1.28.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.28.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
new file mode 100644
index 0000000000..24401bb4be
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch"
13
14SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
15SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
16S = "${WORKDIR}/libxslt-${PV}"
17
18inherit autotools pkgconfig binconfig lib_package
19
20# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
21do_configure_prepend () {
22 sed -i -e 's/ansidecl.h//' ${S}/configure.in
23
24 # The timestamps in the 1.1.28 tarball are messed up causing this file to
25 # appear out of date. Touch it so that we don't try to regenerate it.
26 touch ${S}/doc/xsltproc.1
27}
28
29EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
30# older versions of this recipe had ${PN}-utils
31RPROVIDES_${PN}-bin += "${PN}-utils"
32RCONFLICTS_${PN}-bin += "${PN}-utils"
33RREPLACES_${PN}-bin += "${PN}-utils"
34
35FILES_${PN} += "${libdir}/libxslt-plugins"
36FILES_${PN}-dev += "${libdir}/xsltConf.sh"
37
38BBCLASSEXTEND = "native"