summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libssh2/libssh2_1.11.1.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2024-10-22 16:29:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-10-24 15:18:54 +0100
commit3fa461da7c43a945542294f0aaba4824deb60810 (patch)
tree43455992ff96839fca0c9d476c3da77d467aa192 /meta/recipes-support/libssh2/libssh2_1.11.1.bb
parent5f914f6c174c56ed85e61b96ea4993e31a28866f (diff)
downloadpoky-3fa461da7c43a945542294f0aaba4824deb60810.tar.gz
libssh2: upgrade 1.11.0 -> 1.11.1
Changelog: https://github.com/libssh2/libssh2/releases/tag/libssh2-1.11.1 Patches '0001-disable-DSA-by-default.patch' and 'CVE-2023-48795.patch' were both dropped as they're included in version 1.11.1. License-Update: Copyright symbols were changed from (C) to lowercase (c) ptest results: |root@qemux86-64:~# ptest-runner libssh2 |START: ptest-runner |2024-10-22T20:15 |BEGIN: /usr/lib/libssh2/ptest |PASS: mansyntax.sh |PASS: test_simple |PASS: test_sshd.test |DURATION: 3 |END: /usr/lib/libssh2/ptest |2024-10-22T20:15 |STOP: ptest-runner |TOTAL: 1 FAIL: 0 (From OE-Core rev: bcd178082a50b81405019699d5acc3cd8273b732) Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libssh2/libssh2_1.11.1.bb')
-rw-r--r--meta/recipes-support/libssh2/libssh2_1.11.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/libssh2/libssh2_1.11.1.bb b/meta/recipes-support/libssh2/libssh2_1.11.1.bb
new file mode 100644
index 0000000000..6d2580072b
--- /dev/null
+++ b/meta/recipes-support/libssh2/libssh2_1.11.1.bb
@@ -0,0 +1,52 @@
1SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2fbf8f834408079bf1fcbadb9814b1bc"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://run-ptest \
12 "
13
14SRC_URI[sha256sum] = "d9ec76cbe34db98eec3539fe2c899d26b0c837cb3eb466a56b0f109cabf658f7"
15
16inherit autotools pkgconfig ptest
17
18EXTRA_OECONF += "\
19 --with-libz \
20 --with-libz-prefix=${STAGING_LIBDIR} \
21 --disable-rpath \
22 "
23DISABLE_STATIC = ""
24
25# only one of openssl and gcrypt could be set
26PACKAGECONFIG ??= "openssl"
27PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
28PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
29
30BBCLASSEXTEND = "native nativesdk"
31
32# required for ptest on documentation
33RDEPENDS:${PN}-ptest = "bash man-db openssh"
34RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
35
36do_compile_ptest() {
37 sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
38 oe_runmake check
39}
40
41do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/tests
43 install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
44 cp -rf ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests/
45 cp -rf ${B}/tests/test_simple ${D}${PTEST_PATH}/tests/
46 cp -rf ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
47 cp -rf ${S}/tests/key* ${D}${PTEST_PATH}/tests/
48 cp -rf ${S}/tests/openssh_server/ ${D}${PTEST_PATH}/tests/
49 cp -rf ${S}/tests/*.test ${D}${PTEST_PATH}/tests/
50 mkdir -p ${D}${PTEST_PATH}/docs
51 cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
52}