summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-20 16:11:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:52 +0100
commit159736c28706d73b3949aa5edfb3beec897a7267 (patch)
tree7f8f5a69ead22d16c2ec0ec8ef9bf2cd68423389 /meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb
parent648c8ad5bf75888eb78a68f14c24735ad80ef5bd (diff)
downloadpoky-159736c28706d73b3949aa5edfb3beec897a7267.tar.gz
libsoup-2.4: upgrade 2.66.1 -> 2.66.2
(From OE-Core rev: ba8008e426fbf8417bf08e13393d62ea92669c77) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb
new file mode 100644
index 0000000000..c4715a0412
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.66.2.bb
@@ -0,0 +1,38 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \
13 file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \
14 "
15SRC_URI[md5sum] = "66c2ae89d6031b01337d78a2c57c75d5"
16SRC_URI[sha256sum] = "bd2ea602eba642509672812f3c99b77cbec2f3de02ba1cc8cb7206bf7de0ae2a"
17
18S = "${WORKDIR}/libsoup-${PV}"
19
20inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
21
22# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
25PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5"
26
27EXTRA_OEMESON_append = " -Dvapi=false"
28
29GTKDOC_MESON_OPTION = "doc"
30
31# When built without gnome support, libsoup-2.4 will contain only one shared lib
32# and will therefore become subject to renaming by debian.bbclass. Prevent
33# renaming in order to keep the package name consistent regardless of whether
34# gnome support is enabled or disabled.
35DEBIAN_NOAUTONAME_${PN} = "1"
36
37# glib-networking is needed for SSL, proxies, etc.
38RRECOMMENDS_${PN} = "glib-networking"