summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-04-04 18:32:24 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:03 +0100
commit67526610433699f3145ed73850e727810dfc412b (patch)
tree4fe3b850afe2e540c1f99b2eec38a564c55e123f /meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb
parentd0dc30675229853908101b6ec7a322d45bb8d382 (diff)
downloadpoky-67526610433699f3145ed73850e727810dfc412b.tar.gz
libsoup-2.4: upgrade to version 2.62.0
2.60.3 -> 2.62.0 (From OE-Core rev: cf4cb9d788797411f555235148650c3a6645fd8c) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb
new file mode 100644
index 0000000000..5c9dd19cbd
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.62.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
13
14SRC_URI[md5sum] = "750b6f6136e5fdd82ac07f60b4aea575"
15SRC_URI[sha256sum] = "ab7c7ae8d19d0a27ab3b6ae21599cec8c7f7b773b3f2b1090c5daf178373aaac"
16
17S = "${WORKDIR}/libsoup-${PV}"
18
19inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
20
21# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
24PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
25
26EXTRA_OECONF = "--disable-vala"
27
28# When built without gnome support, libsoup-2.4 will contain only one shared lib
29# and will therefore become subject to renaming by debian.bbclass. Prevent
30# renaming in order to keep the package name consistent regardless of whether
31# gnome support is enabled or disabled.
32DEBIAN_NOAUTONAME_${PN} = "1"
33
34# glib-networking is needed for SSL, proxies, etc.
35RRECOMMENDS_${PN} = "glib-networking"