summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libseccomp/libseccomp_2.5.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-09-30 21:54:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:41:39 +0100
commit2eb0630516dc0df5cc8fde3e2744550b0830a656 (patch)
treebdb530b6416b496844bd51acc665fffb05c7d399 /meta/recipes-support/libseccomp/libseccomp_2.5.1.bb
parented32b9ebe9f3525da05e84342f357c59478e10f9 (diff)
downloadpoky-2eb0630516dc0df5cc8fde3e2744550b0830a656.tar.gz
libseccomp: Upgrade to 2.5.2 and beyond
Forward port the rv32 port (From OE-Core rev: 269133fed2854cdfe9c23a17a86fb1f1ea7e11cb) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libseccomp/libseccomp_2.5.1.bb')
-rw-r--r--meta/recipes-support/libseccomp/libseccomp_2.5.1.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.1.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.1.bb
deleted file mode 100644
index 74bface4a1..0000000000
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.1.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
5LICENSE = "LGPL-2.1"
6LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
7
8DEPENDS += "gperf-native"
9
10PV .= "+git${SRCPV}"
11SRCREV = "5822e50c2920ce597d038077dea4a0eedf193f86"
12
13SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=main \
14 file://0001-configure.ac-Bump-version-to-2.5.99.patch \
15 file://0001-arch-Add-riscv32-architecture-support.patch \
16 file://0002-Regenerate-syscall-cvs-file-from-5.13-rc5-kernel.patch \
17 file://run-ptest \
18 "
19
20S = "${WORKDIR}/git"
21
22inherit autotools-brokensep pkgconfig ptest features_check
23
24REQUIRED_DISTRO_FEATURES = "seccomp"
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
28
29DISABLE_STATIC = ""
30
31do_compile_ptest() {
32 oe_runmake -C tests check-build
33}
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 install -d ${D}${PTEST_PATH}/tools
38 for file in $(find tests/* -executable -type f); do
39 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
40 done
41 for file in $(find tests/*.tests -type f); do
42 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
43 done
44 for file in $(find tools/* -executable -type f); do
45 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
46 done
47 # Overwrite libtool wrappers with real executables
48 for file in $(find tools/.libs/* -executable -type f); do
49 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
50 done
51}
52
53FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
54FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
55
56RDEPENDS:${PN}-ptest = "coreutils bash"