summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.34.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-01-03 16:38:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:14:01 +0000
commit12c181f5ed348bdd0dd24040ec749858b223ceee (patch)
tree38332adec16007765f22d2ca0dc90802ca4c8457 /meta/recipes-support/libpcre/libpcre_8.34.bb
parent5b711eb91ec63f4b977778ca74a7a6a1163536f9 (diff)
downloadpoky-12c181f5ed348bdd0dd24040ec749858b223ceee.tar.gz
libpcre: upgrade to 8.34
Upgrade libpcre to 8.34. (From OE-Core rev: 11f90a720194499447f9b6e738fd56d78a0c2fee) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.34.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.34.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.34.bb b/meta/recipes-support/libpcre/libpcre_8.34.bb
new file mode 100644
index 0000000000..0c2b0828b1
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.34.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=0920cc1a9f7ba95464491fa83c86afd8"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch \
12 file://fix-pcre-name-collision.patch"
13
14SRC_URI[md5sum] = "5439e321351bddd5533551bbce128d07"
15SRC_URI[sha256sum] = "b6043ae1ff2720be665ffa28dc22b7c637cdde96f389a116c0c3020caeae583f"
16
17S = "${WORKDIR}/pcre-${PV}"
18
19PROVIDES += "pcre"
20DEPENDS += "bzip2 zlib"
21
22PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
23
24inherit autotools binconfig
25
26PARALLEL_MAKE = ""
27
28EXTRA_OECONF = "\
29 --enable-newline-is-lf \
30 --enable-rebuild-chartables \
31 --enable-utf8 \
32 --with-link-size=2 \
33 --with-match-limit=10000000 \
34"
35
36# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
37# set CFLAGS_FOR_BUILD, required for the libpcre build.
38BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}"
39CFLAGS += "-D_REENTRANT"
40CXXFLAGS_append_powerpc = " -lstdc++"
41
42PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
43
44SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
45SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
46SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
47SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
48SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
49SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
50
51FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
52FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
53FILES_pcregrep = "${bindir}/pcregrep"
54FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
55FILES_pcretest = "${bindir}/pcretest"
56FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
57
58BBCLASSEXTEND = "native nativesdk"