summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre2_10.35.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-31 17:52:48 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:31 +0100
commitea5cf25579e72cbf523ac680db613a4944d7bb1a (patch)
treeda1530d88f1c7d441df06420b85ce284522aa4fa /meta/recipes-support/libpcre/libpcre2_10.35.bb
parent94c710cf1139d8fb98598d91b8d6fad82f21aaf8 (diff)
downloadpoky-ea5cf25579e72cbf523ac680db613a4944d7bb1a.tar.gz
libcpre2: update 10.34 -> 10.35
Replace pcre-cross.patch with the (default) option to use pre-built tables; the README says it's ok, and recommended in cross-compile situations. The option was in the recipe from the start and neither the commit that adds the recipe, nor the patch to make it work explain why. License-Update: copyright years (From OE-Core rev: df85581e8ac01183b13dd7c3e926ee93f50214f2) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre2_10.35.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre2_10.35.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre2_10.35.bb b/meta/recipes-support/libpcre/libpcre2_10.35.bb
new file mode 100644
index 0000000000..35c019c100
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre2_10.35.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD-3-Clause"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=a06590e9bd4c229532364727aaeaf084"
12
13SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2"
14
15SRC_URI[sha256sum] = "9ccba8e02b0ce78046cdfb52e5c177f0f445e421059e43becca4359c669d4613"
16
17CVE_PRODUCT = "pcre2"
18
19S = "${WORKDIR}/pcre2-${PV}"
20
21PROVIDES += "pcre2"
22DEPENDS += "bzip2 zlib"
23
24BINCONFIG = "${bindir}/pcre2-config"
25
26inherit autotools binconfig-disabled
27
28EXTRA_OECONF = "\
29 --enable-newline-is-lf \
30 --with-link-size=2 \
31 --with-match-limit=10000000 \
32 --enable-pcre2-16 \
33 --enable-pcre2-32 \
34"
35CFLAGS += "-D_REENTRANT"
36CXXFLAGS_append_powerpc = " -lstdc++"
37
38PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
39
40SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
41SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
42SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
43SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
44
45FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*"
46FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*"
47FILES_pcre2grep = "${bindir}/pcre2grep"
48FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
49FILES_pcre2test = "${bindir}/pcre2test"
50FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
51
52BBCLASSEXTEND = "native nativesdk"