summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl_3.5.0.bb
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-02-19 01:03:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-21 22:01:28 +0000
commitd920e8cb33bc82945cefa2371c5a491dd28fd1b4 (patch)
tree4080a85dbe4f0d7d7e1b44219a8a59c12a441dcf /meta/recipes-support/libnl/libnl_3.5.0.bb
parentd54cada0629176ba916ad48103cbb62436561062 (diff)
downloadpoky-d920e8cb33bc82945cefa2371c5a491dd28fd1b4.tar.gz
libnl: add ptest support
All tests are installed, but only what `make check` runs is run, so currently that's 1 test named `check-all` `libcheck` needs to be present for ./configure to generate the check* tests. An issue asking about upstream testing strategy is opened at https://github.com/thom311/libnl/issues/270 (From OE-Core rev: 23a785a373f76a24f4f7dd867522ce296cbf30f3) Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libnl/libnl_3.5.0.bb')
-rw-r--r--meta/recipes-support/libnl/libnl_3.5.0.bb30
1 files changed, 28 insertions, 2 deletions
diff --git a/meta/recipes-support/libnl/libnl_3.5.0.bb b/meta/recipes-support/libnl/libnl_3.5.0.bb
index 9d0e1441a9..09d8c8611e 100644
--- a/meta/recipes-support/libnl/libnl_3.5.0.bb
+++ b/meta/recipes-support/libnl/libnl_3.5.0.bb
@@ -9,19 +9,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
9 9
10DEPENDS = "flex-native bison-native" 10DEPENDS = "flex-native bison-native"
11 11
12SRC_URI = "https://github.com/thom311/${BPN}/releases/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz" 12SRC_URI = " \
13 https://github.com/thom311/${BPN}/releases/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz \
14 file://enable-serial-tests.patch \
15 file://run-ptest \
16 "
17
13SRC_URI[md5sum] = "74ba57b1b1d6f9f92268aa8141d8e8e4" 18SRC_URI[md5sum] = "74ba57b1b1d6f9f92268aa8141d8e8e4"
14SRC_URI[sha256sum] = "352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa" 19SRC_URI[sha256sum] = "352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa"
15 20
21
16UPSTREAM_CHECK_URI = "https://github.com/thom311/${BPN}/releases" 22UPSTREAM_CHECK_URI = "https://github.com/thom311/${BPN}/releases"
17 23
18inherit autotools pkgconfig 24inherit autotools pkgconfig ptest
19 25
20FILES_${PN} = "${libdir}/libnl-3.so.* \ 26FILES_${PN} = "${libdir}/libnl-3.so.* \
21 ${libdir}/libnl.so.* \ 27 ${libdir}/libnl.so.* \
22 ${sysconfdir}" 28 ${sysconfdir}"
23RREPLACES_${PN} = "libnl2" 29RREPLACES_${PN} = "libnl2"
24RCONFLICTS_${PN} = "libnl2" 30RCONFLICTS_${PN} = "libnl2"
31
25FILES_${PN}-dev += "${libdir}/libnl/cli/*/*.la" 32FILES_${PN}-dev += "${libdir}/libnl/cli/*/*.la"
26FILES_${PN}-staticdev += "${libdir}/libnl/cli/*/*.a" 33FILES_${PN}-staticdev += "${libdir}/libnl/cli/*/*.a"
27 34
@@ -41,4 +48,23 @@ FILES_${PN}-xfrm = "${libdir}/libnl-xfrm-3.so.*"
41RREPLACES_${PN}-genl = "libnl-genl2" 48RREPLACES_${PN}-genl = "libnl-genl2"
42RCONFLICTS_${PN}-genl = "libnl-genl2" 49RCONFLICTS_${PN}-genl = "libnl-genl2"
43 50
51RDEPENDS_${PN}-ptest += "libcheck"
52DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'libcheck', '', d)}"
53
54# make sure the tests don't link against wrong so file
55EXTRA_OECONF += "${@bb.utils.contains('PTEST_ENABLED', '1', '--disable-rpath', '', d)}"
56
57do_compile_ptest() {
58 # hack to remove the call to `make runtest-TESTS`
59 sed -i 's/$(MAKE) $(AM_MAKEFLAGS) runtest-TESTS//g' Makefile
60 oe_runmake check
61}
62
63do_install_ptest(){
64 # legacy? tests are also installed, but ptest-runner will not run them
65 # upstream are not running these tests in their CI pipeline
66 # issue opened https://github.com/thom311/libnl/issues/270
67 install -m 0755 tests/.libs/* ${D}${PTEST_PATH}/
68}
69
44BBCLASSEXTEND = "native nativesdk" 70BBCLASSEXTEND = "native nativesdk"