summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl_3.5.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-05 07:04:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-05 21:17:37 +0100
commitbf6c6623612d2712e5f99818f0f5ed8905bc90cc (patch)
treeeae18ff673c97fb901588a8a9975f4b984f65ba5 /meta/recipes-support/libnl/libnl_3.5.0.bb
parent3d2a3d92fe3e2091af6474b95dd16bac8a63ea42 (diff)
downloadpoky-bf6c6623612d2712e5f99818f0f5ed8905bc90cc.tar.gz
libnl: upgrade 3.5.0 -> 3.6.0
(From OE-Core rev: 09bdeeabf03b6ca1c5410dc7573571554cf172ce) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libnl/libnl_3.5.0.bb')
-rw-r--r--meta/recipes-support/libnl/libnl_3.5.0.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/meta/recipes-support/libnl/libnl_3.5.0.bb b/meta/recipes-support/libnl/libnl_3.5.0.bb
deleted file mode 100644
index 41d7a9aed8..0000000000
--- a/meta/recipes-support/libnl/libnl_3.5.0.bb
+++ /dev/null
@@ -1,75 +0,0 @@
1SUMMARY = "A library for applications dealing with netlink sockets"
2DESCRIPTION = "The libnl suite is a collection of libraries providing \
3APIs to netlink protocol based Linux kernel interfaces. libnl is the core \
4library implementing the fundamentals required to use the netlink protocol \
5such as socket handling, message construction and parsing, and sending \
6and receiving of data."
7HOMEPAGE = "http://www.infradead.org/~tgr/libnl/"
8SECTION = "libs/network"
9
10PE = "1"
11
12LICENSE = "LGPL-2.1-only"
13LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
14
15DEPENDS = "flex-native bison-native"
16
17SRC_URI = " \
18 https://github.com/thom311/${BPN}/releases/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz \
19 file://enable-serial-tests.patch \
20 file://run-ptest \
21 "
22
23SRC_URI[md5sum] = "74ba57b1b1d6f9f92268aa8141d8e8e4"
24SRC_URI[sha256sum] = "352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa"
25
26
27UPSTREAM_CHECK_URI = "https://github.com/thom311/${BPN}/releases"
28
29inherit autotools pkgconfig ptest
30
31FILES:${PN} = "${libdir}/libnl-3.so.* \
32 ${libdir}/libnl.so.* \
33 ${sysconfdir}"
34RREPLACES:${PN} = "libnl2"
35RCONFLICTS:${PN} = "libnl2"
36
37FILES:${PN}-dev += "${libdir}/libnl/cli/*/*.la"
38FILES:${PN}-staticdev += "${libdir}/libnl/cli/*/*.a"
39
40PACKAGES += "${PN}-cli ${PN}-genl ${PN}-idiag ${PN}-nf ${PN}-route ${PN}-xfrm"
41FILES:${PN}-cli = "${libdir}/libnl-cli-3.so.* \
42 ${libdir}/libnl/cli/*/*.so \
43 ${bindir}/genl-ctrl-list \
44 ${bindir}/idiag-socket-details \
45 ${bindir}/nf-* \
46 ${bindir}/nl-*"
47FILES:${PN}-genl = "${libdir}/libnl-genl-3.so.* \
48 ${libdir}/libnl-genl.so.*"
49FILES:${PN}-idiag = "${libdir}/libnl-idiag-3.so.*"
50FILES:${PN}-nf = "${libdir}/libnl-nf-3.so.*"
51FILES:${PN}-route = "${libdir}/libnl-route-3.so.*"
52FILES:${PN}-xfrm = "${libdir}/libnl-xfrm-3.so.*"
53RREPLACES:${PN}-genl = "libnl-genl2"
54RCONFLICTS:${PN}-genl = "libnl-genl2"
55
56RDEPENDS:${PN}-ptest += "libcheck"
57DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'libcheck', '', d)}"
58
59# make sure the tests don't link against wrong so file
60EXTRA_OECONF += "${@bb.utils.contains('PTEST_ENABLED', '1', '--disable-rpath', '', d)}"
61
62do_compile_ptest() {
63 # hack to remove the call to `make runtest-TESTS`
64 sed -i 's/$(MAKE) $(AM_MAKEFLAGS) runtest-TESTS//g' Makefile
65 oe_runmake check
66}
67
68do_install_ptest(){
69 # legacy? tests are also installed, but ptest-runner will not run them
70 # upstream are not running these tests in their CI pipeline
71 # issue opened https://github.com/thom311/libnl/issues/270
72 install -m 0755 tests/.libs/* ${D}${PTEST_PATH}/
73}
74
75BBCLASSEXTEND = "native nativesdk"