summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb
diff options
context:
space:
mode:
authorNarpat Mali <narpat.mali@windriver.com>2023-03-08 14:26:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-20 17:20:44 +0000
commitcaa3177c77d951cf3d48e3fc73e8aba814d026ae (patch)
tree870a19f67ce276db80ec0319002c35b5c1ee1a0f /meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb
parent015945091eef263e49a8adfa3c5184b7c7f97326 (diff)
downloadpoky-caa3177c77d951cf3d48e3fc73e8aba814d026ae.tar.gz
libmicrohttpd: upgrade 0.9.75 -> 0.9.76
Changelog: ============ Fix potential DoS vector in MHD_PostProcessor.(CVE-2023-27371) Releasing GNU libmicrohttpd 0.9.76 hotfix. https://github.com/Karlson2k/libmicrohttpd/blob/v0.9.76/ChangeLog (From OE-Core rev: 017346be6c97d20b1b16d495ee9484f10973857c) Signed-off-by: Narpat Mali <narpat.mali@windriver.com> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb')
-rw-r--r--meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb
new file mode 100644
index 0000000000..ad3c34ab9e
--- /dev/null
+++ b/meta/recipes-support/libmicrohttpd/libmicrohttpd_0.9.76.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
10SRC_URI[sha256sum] = "f0b1547b5a42a6c0f724e8e1c1cb5ce9c4c35fb495e7d780b9930d35011ceb4c"
11
12inherit autotools lib_package pkgconfig gettext
13
14CFLAGS += "-pthread -D_REENTRANT"
15
16EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
17
18PACKAGECONFIG ?= "curl https"
19PACKAGECONFIG:append:class-target = "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
21"
22PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
23PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
24PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
25
26do_compile:append() {
27 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
28}
29
30BBCLASSEXTEND = "native nativesdk"