summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-02-28 16:36:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-10 10:30:39 +0000
commitbe8062b07134f48764894d80adb8d9af54a9c0f7 (patch)
treef968d9c783cc61c9fe09ea228013871f08693e04 /meta/recipes-support/libical/libical_3.0.8.bb
parentbc177f47c512eace971d62ea91587626fff1224b (diff)
downloadpoky-be8062b07134f48764894d80adb8d9af54a9c0f7.tar.gz
libical: update 3.0.8 -> 3.0.9
Upstream attempted to fix cross-compilation, but seems to have broken it, so a new ticket was filed, and patch to un-break it was rewritten. (From OE-Core rev: 062b1d1092b451f36af064b30f73326c0b5e5e4d) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.8.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.8.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.8.bb b/meta/recipes-support/libical/libical_3.0.8.bb
deleted file mode 100644
index ffc117d439..0000000000
--- a/meta/recipes-support/libical/libical_3.0.8.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2DESCRIPTION = "An Open Source implementation of the iCalendar protocols \
3and protocol data units. The iCalendar specification describes how \
4calendar clients can communicate with calendar servers so users can store \
5their calendar data and arrange meetings with other users. "
6HOMEPAGE = "https://github.com/libical/libical"
7BUGTRACKER = "https://github.com/libical/libical/issues"
8LICENSE = "LGPLv2.1 | MPL-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
10 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
11 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
12 "
13SECTION = "libs"
14
15SRC_URI = " \
16 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
17 file://0001-Use-our-hand-build-native-src-generator.patch \
18 file://0001-Fix-build-with-icu-68.1.patch \
19"
20SRC_URI[md5sum] = "41bd1f1fcdcb4779cea478bb55cf07bf"
21SRC_URI[sha256sum] = "09fecacaf75ba5a242159e3a9758a5446b5ce4d0ab684f98a7040864e1d1286f"
22UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
23
24inherit cmake pkgconfig
25
26do_compile_prepend() {
27 # As long as https://github.com/libical/libical/issues/394 is open build native src-generator manually
28 NATIVE_CFLAGS="${BUILD_CFLAGS} `pkg-config-native --cflags glib-2.0` `pkg-config-native --cflags libxml-2.0`"
29 NATIVE_LDFLAGS="${BUILD_LDFLAGS} `pkg-config-native --libs glib-2.0` `pkg-config-native --libs libxml-2.0`"
30 ${BUILD_CC} $NATIVE_CFLAGS ${S}/src/libical-glib/tools/generator.c ${S}/src/libical-glib/tools/xml-parser.c -o ${B}/src-generator $NATIVE_LDFLAGS
31}
32
33PACKAGECONFIG ??= "icu glib"
34PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
35PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
36# ICU is used for RSCALE (RFC7529) support
37PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
38
39# No need to use perl-native, the host perl is sufficient.
40EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
41# doc build fails with linker error (??) for libical-glib so disable it
42EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
43
44do_install_append () {
45 # Remove build host references
46 sed -i \
47 -e 's,${STAGING_LIBDIR},${libdir},g' \
48 -e 's,${STAGING_INCDIR},${includedir},g' \
49 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake
50}