summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-31 17:52:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:30 +0100
commit65ebaf076d64ddfcd4d5ef072724e2e4ad22cc37 (patch)
tree36ef20025072efebd20016aa417959a5a772fd6e /meta/recipes-support/libical/libical_3.0.8.bb
parent42ac4b97b998ad6c5f54564a67c8d5171b0e58dc (diff)
downloadpoky-65ebaf076d64ddfcd4d5ef072724e2e4ad22cc37.tar.gz
libical: upgrade 3.0.7 -> 3.0.8
(From OE-Core rev: ac561e63479716574ee980b28644415486b13fda) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.8.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.8.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.8.bb b/meta/recipes-support/libical/libical_3.0.8.bb
new file mode 100644
index 0000000000..efb9433412
--- /dev/null
+++ b/meta/recipes-support/libical/libical_3.0.8.bb
@@ -0,0 +1,45 @@
1SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2HOMEPAGE = "https://github.com/libical/libical"
3BUGTRACKER = "https://github.com/libical/libical/issues"
4LICENSE = "LGPLv2.1 | MPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
6 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
7 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
8 "
9SECTION = "libs"
10
11SRC_URI = " \
12 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
13 file://0001-Use-our-hand-build-native-src-generator.patch \
14"
15SRC_URI[md5sum] = "41bd1f1fcdcb4779cea478bb55cf07bf"
16SRC_URI[sha256sum] = "09fecacaf75ba5a242159e3a9758a5446b5ce4d0ab684f98a7040864e1d1286f"
17UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
18
19inherit cmake pkgconfig
20
21do_compile_prepend() {
22 # As long as https://github.com/libical/libical/issues/394 is open build native src-generator manually
23 NATIVE_CFLAGS="${BUILD_CFLAGS} `pkg-config-native --cflags glib-2.0` `pkg-config-native --cflags libxml-2.0`"
24 NATIVE_LDFLAGS="${BUILD_LDFLAGS} `pkg-config-native --libs glib-2.0` `pkg-config-native --libs libxml-2.0`"
25 ${BUILD_CC} $NATIVE_CFLAGS ${S}/src/libical-glib/tools/generator.c ${S}/src/libical-glib/tools/xml-parser.c -o ${B}/src-generator $NATIVE_LDFLAGS
26}
27
28PACKAGECONFIG ??= "icu glib"
29PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
30PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
31# ICU is used for RSCALE (RFC7529) support
32PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
33
34# No need to use perl-native, the host perl is sufficient.
35EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
36# doc build fails with linker error (??) for libical-glib so disable it
37EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
38
39do_install_append () {
40 # Remove build host references
41 sed -i \
42 -e 's,${STAGING_LIBDIR},${libdir},g' \
43 -e 's,${STAGING_INCDIR},${includedir},g' \
44 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake
45}