summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-02-28 16:36:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-02 14:15:33 +0000
commit31421cc447f15fdcd5ad023bebca451282764750 (patch)
tree0d9ea946902d063efa12f39a961dad8b230f190a /meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb
parentde8475d206d6b17c6b7907ed06f73c6586cf4f48 (diff)
downloadpoky-31421cc447f15fdcd5ad023bebca451282764750.tar.gz
libgcrypt: update 1.8.7 -> 1.9.2
Drop backports. Add a patch that inserts missing spaces in Makefiles. Drop determinism.patch: upstream has moved the git stuff to an external script, which has a guard that checkes for presence of .git/ in source tree. License-Update: additional source file listed (From OE-Core rev: ad2eae801c7809db3f4830f19efdad78d1a62d59) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb
new file mode 100644
index 0000000000..df49177f16
--- /dev/null
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.9.2.bb
@@ -0,0 +1,58 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=2dae15d91a37cfde72fe9eae75f8ea14 \
15 "
16
17DEPENDS = "libgpg-error"
18
19UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
20SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
21 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
22 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
23 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
24 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
25 file://0001-Makefile.am-add-a-missing-space.patch \
26 "
27SRC_URI[sha256sum] = "b2c10d091513b271e47177274607b1ffba3d95b188bbfa8797f948aec9053c5a"
28
29# Below whitelisted CVEs are disputed and not affecting crypto libraries for any distro.
30CVE_CHECK_WHITELIST += "CVE-2018-12433 CVE-2018-12438"
31
32BINCONFIG = "${bindir}/libgcrypt-config"
33
34inherit autotools texinfo binconfig-disabled pkgconfig
35
36EXTRA_OECONF = "--disable-asm"
37EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
38
39PACKAGECONFIG ??= "capabilities"
40PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
41
42do_configure_prepend () {
43 # Else this could be used in preference to the one in aclocal-copy
44 rm -f ${S}/m4/gpg-error.m4
45}
46
47# libgcrypt.pc is added locally and thus installed here
48do_install_append() {
49 install -d ${D}/${libdir}/pkgconfig
50 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
51}
52
53PACKAGES =+ "dumpsexp-dev"
54
55FILES_${PN}-dev += "${bindir}/hmac256"
56FILES_dumpsexp-dev += "${bindir}/dumpsexp"
57
58BBCLASSEXTEND = "native nativesdk"