summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:49:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:21:12 +0000
commit38250886b8a796a4d6e3caeb225c61b51396e1e0 (patch)
tree639e3dcf8500baaf52e5bdc80c82171c620af983 /meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb
parentb6721c66dedf7521ecb88d2159f2a44560f14338 (diff)
downloadpoky-38250886b8a796a4d6e3caeb225c61b51396e1e0.tar.gz
libgcrypt: upgrade 1.8.6 -> 1.8.7
(From OE-Core rev: 15f1143ad34586740dd782506ff393c4f3735614) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb
new file mode 100644
index 0000000000..0cad41dfa9
--- /dev/null
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.8.7.bb
@@ -0,0 +1,57 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
20 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
21 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
22 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
23 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
24 file://0001-Prefetch-GCM-look-up-tables.patch \
25 file://0002-AES-move-look-up-tables-to-.data-section-and-unshare.patch \
26 file://0003-GCM-move-look-up-table-to-.data-section-and-unshare-.patch \
27 file://determinism.patch \
28"
29SRC_URI[sha256sum] = "03b70f028299561b7034b8966d7dd77ef16ed139c43440925fe8782561974748"
30
31BINCONFIG = "${bindir}/libgcrypt-config"
32
33inherit autotools texinfo binconfig-disabled pkgconfig
34
35EXTRA_OECONF = "--disable-asm"
36EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
37
38PACKAGECONFIG ??= "capabilities"
39PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
40
41do_configure_prepend () {
42 # Else this could be used in preference to the one in aclocal-copy
43 rm -f ${S}/m4/gpg-error.m4
44}
45
46# libgcrypt.pc is added locally and thus installed here
47do_install_append() {
48 install -d ${D}/${libdir}/pkgconfig
49 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
50}
51
52PACKAGES =+ "dumpsexp-dev"
53
54FILES_${PN}-dev += "${bindir}/hmac256"
55FILES_dumpsexp-dev += "${bindir}/dumpsexp"
56
57BBCLASSEXTEND = "native nativesdk"