summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-15 09:44:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-18 11:06:32 +0100
commitd0bc9cee83b5c5c5d5d0cc4228c165dde2d94b90 (patch)
treebb80c757f5305d2ed0a4473b51ee927b02fcc5f2 /meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb
parent16770d5970c735f0941861abc8981962e8e43746 (diff)
downloadpoky-d0bc9cee83b5c5c5d5d0cc4228c165dde2d94b90.tar.gz
libgcrypt: upgrade 1.8.5 -> 1.8.6
(From OE-Core rev: 260ea206a0729de9c31e8635474188604ef73332) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb
deleted file mode 100644
index 4e0eb0a169..0000000000
--- a/meta/recipes-support/libgcrypt/libgcrypt_1.8.5.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
20 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
21 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
22 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
23 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
24 file://0001-Prefetch-GCM-look-up-tables.patch \
25 file://0002-AES-move-look-up-tables-to-.data-section-and-unshare.patch \
26 file://0003-GCM-move-look-up-table-to-.data-section-and-unshare-.patch \
27 file://determinism.patch \
28"
29SRC_URI[md5sum] = "348cc4601ca34307fc6cd6c945467743"
30SRC_URI[sha256sum] = "3b4a2a94cb637eff5bdebbcaf46f4d95c4f25206f459809339cdada0eb577ac3"
31
32BINCONFIG = "${bindir}/libgcrypt-config"
33
34inherit autotools texinfo binconfig-disabled pkgconfig
35
36EXTRA_OECONF = "--disable-asm"
37EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
38
39PACKAGECONFIG ??= "capabilities"
40PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
41
42do_configure_prepend () {
43 # Else this could be used in preference to the one in aclocal-copy
44 rm -f ${S}/m4/gpg-error.m4
45}
46
47# libgcrypt.pc is added locally and thus installed here
48do_install_append() {
49 install -d ${D}/${libdir}/pkgconfig
50 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
51}
52
53PACKAGES =+ "dumpsexp-dev"
54
55FILES_${PN}-dev += "${bindir}/hmac256"
56FILES_dumpsexp-dev += "${bindir}/dumpsexp"
57
58BBCLASSEXTEND = "native nativesdk"