summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-10-29 12:29:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:39:05 +0000
commitb8f8707dfe1ba2c98871b42a1a2d28d14b0f67a8 (patch)
tree206cf6ce2de14a5c341d3d9a0cbc91100f7156a5 /meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb
parent421b8d43abaed391d7ce18a34bf6f310f9126b2e (diff)
downloadpoky-b8f8707dfe1ba2c98871b42a1a2d28d14b0f67a8.tar.gz
libgcrypt: upgrade 1.8.4 -> 1.8.5
Upgrade libgcrypt. Upstream repo now has a pkg-config feature. The new patch for compatibility with oe-core is a replacement for a patch that added pkg-config as a feature when upstream did not have it. (From OE-Core rev: 53b73a39ae4a4c8db19fb18ef1881033f6b9ff51) Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb
deleted file mode 100644
index 11d078d44a..0000000000
--- a/meta/recipes-support/libgcrypt/libgcrypt_1.8.4.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
20 file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \
21 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
22 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
23 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
24 file://0001-Prefetch-GCM-look-up-tables.patch \
25 file://0002-AES-move-look-up-tables-to-.data-section-and-unshare.patch \
26 file://0003-GCM-move-look-up-table-to-.data-section-and-unshare-.patch \
27"
28SRC_URI[md5sum] = "fbfdaebbbc6d7e5fbbf6ffdb3e139573"
29SRC_URI[sha256sum] = "f638143a0672628fde0cad745e9b14deb85dffb175709cacc1f4fe24b93f2227"
30
31BINCONFIG = "${bindir}/libgcrypt-config"
32
33inherit autotools texinfo binconfig-disabled pkgconfig
34
35EXTRA_OECONF = "--disable-asm"
36EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
37
38PACKAGECONFIG ??= "capabilities"
39PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
40
41do_configure_prepend () {
42 # Else this could be used in preference to the one in aclocal-copy
43 rm -f ${S}/m4/gpg-error.m4
44}
45
46# libgcrypt.pc is added locally and thus installed here
47do_install_append() {
48 install -d ${D}/${libdir}/pkgconfig
49 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
50}
51
52PACKAGES =+ "dumpsexp-dev"
53
54FILES_${PN}-dev += "${bindir}/hmac256"
55FILES_dumpsexp-dev += "${bindir}/dumpsexp"
56
57BBCLASSEXTEND = "native nativesdk"