summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libfm/libfm_1.2.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-15 14:47:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-17 09:57:03 +0000
commitac3adfb91cdc1aa63280ffca2095ad814d293873 (patch)
treea9ee3d1737cbd85e92e795ee684adc7faac0ed87 /meta/recipes-support/libfm/libfm_1.2.5.bb
parentffda25aa96b190a783dee777e0913adf23667be3 (diff)
downloadpoky-ac3adfb91cdc1aa63280ffca2095ad814d293873.tar.gz
libfm: update to 1.2.5
(From OE-Core rev: 4674c0894c268690735b433df40e397c85a073a8) (From OE-Core rev: 0fc419c9e58ca37cf523496b12ba65171d5abb50) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libfm/libfm_1.2.5.bb')
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.5.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/libfm/libfm_1.2.5.bb b/meta/recipes-support/libfm/libfm_1.2.5.bb
new file mode 100644
index 0000000000..638c364c87
--- /dev/null
+++ b/meta/recipes-support/libfm/libfm_1.2.5.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Library for file management"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3
4LICENSE = "GPLv2+ & LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4641e94ec96f98fabc56ff9cc48be14b \
6 file://src/fm.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007 \
7 file://src/base/fm-config.h;beginline=10;endline=23;md5=ef1f84da64b3c01cca447212f7ef6007 \
8 file://src/fm-gtk.h;beginline=6;endline=19;md5=646baa4955c04fe768f2ca27b92ac8dd"
9
10
11SECTION = "x11/libs"
12DEPENDS = "glib-2.0 pango gtk+3 menu-cache intltool-native libexif libfm-extra gettext-native"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz"
15
16SRC_URI[md5sum] = "a1ba9ae5e920f38b647dd511edd6c807"
17SRC_URI[sha256sum] = "c706bb1020cf5f2d6f5a9226f692ce1985947134dcf2bde64278bd0420779b5a"
18
19inherit autotools pkgconfig gtk-doc distro_features_check
20ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
21
22EXTRA_OECONF = "--with-gtk=3"
23
24do_configure[dirs] =+ "${S}/m4"
25
26PACKAGES += "${PN}-mime"
27FILES_${PN}-mime = "${datadir}/mime/"
28
29do_install_append () {
30 # remove files which are part of libfm-extra
31 rm -f ${D}${includedir}/libfm-1.0/fm-xml-file.h
32 rm -f ${D}${includedir}/libfm-1.0/fm-version.h
33 rm -f ${D}${includedir}/libfm-1.0/fm-extra.h
34 rm -f ${D}${libdir}/pkgconfig/libfm-extra.pc
35 rm -f ${D}${libdir}/libfm-extra.so*
36 rm -f ${D}${libdir}/libfm-extra.a
37 rm -f ${D}${libdir}/libfm-extra.la
38}