summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libfm/libfm_1.2.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-24 15:40:16 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:33:04 +0000
commit6b4160892346facb2f786b6a9dd576ca6a8a879b (patch)
treed4abcf0011b26f9696bbb206d56e97b34755ee53 /meta/recipes-support/libfm/libfm_1.2.4.bb
parent325a9d3692e4f2c5373e3a3616a1af23daf7be2c (diff)
downloadpoky-6b4160892346facb2f786b6a9dd576ca6a8a879b.tar.gz
libfm: update to 1.2.4
LICENSE checksum change due to formatting changes, and 'how to apply those terms' section dropped from the GPL text. (From OE-Core rev: 0fad6dbccbf63afa2636acf23a33ee06bbdeec30) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libfm/libfm_1.2.4.bb')
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/libfm/libfm_1.2.4.bb b/meta/recipes-support/libfm/libfm_1.2.4.bb
new file mode 100644
index 0000000000..866b11a9aa
--- /dev/null
+++ b/meta/recipes-support/libfm/libfm_1.2.4.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Library for file management"
2HOMEPAGE = "http://pcmanfm.sourceforge.net/"
3
4LICENSE = "GPLv2+ & LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4641e94ec96f98fabc56ff9cc48be14b \
6 file://src/fm.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007 \
7 file://src/base/fm-config.h;beginline=10;endline=23;md5=ef1f84da64b3c01cca447212f7ef6007 \
8 file://src/fm-gtk.h;beginline=6;endline=19;md5=646baa4955c04fe768f2ca27b92ac8dd"
9
10
11SECTION = "x11/libs"
12DEPENDS = "glib-2.0 pango gtk+ menu-cache intltool-native libexif libfm-extra gettext-native"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz"
15
16SRC_URI[md5sum] = "74997d75e7e87dc73398746fd373bf52"
17SRC_URI[sha256sum] = "7804f6f28cb3d1bc8ffb3151ab7ff0c063b27c5f9b06c682eb903e01cf25502f"
18
19inherit autotools pkgconfig gtk-doc distro_features_check
20ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
21
22do_configure[dirs] =+ "${S}/m4"
23
24PACKAGES += "${PN}-mime"
25FILES_${PN}-mime = "${datadir}/mime/"
26
27do_install_append () {
28 # remove files which are part of libfm-extra
29 rm -f ${D}${includedir}/libfm-1.0/fm-xml-file.h
30 rm -f ${D}${includedir}/libfm-1.0/fm-version.h
31 rm -f ${D}${includedir}/libfm-1.0/fm-extra.h
32 rm -f ${D}${libdir}/pkgconfig/libfm-extra.pc
33 rm -f ${D}${libdir}/libfm-extra.so*
34 rm -f ${D}${libdir}/libfm-extra.a
35 rm -f ${D}${libdir}/libfm-extra.la
36}