summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libexif/libexif_0.6.22.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-31 17:52:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:30 +0100
commit83ba71a3057dba1d8ac2f9c15663c9ba9ad833f4 (patch)
tree31f302cc5d55041dd3c280c51e5cec8d6c140032 /meta/recipes-support/libexif/libexif_0.6.22.bb
parentf13961a9d1f76769cad27cbebe981b5e7ec41c94 (diff)
downloadpoky-83ba71a3057dba1d8ac2f9c15663c9ba9ad833f4.tar.gz
libexif: update to 0.6.22
(From OE-Core rev: 76e8c645cb2568c2dfa014af0eeac36d8f8b60ff) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libexif/libexif_0.6.22.bb')
-rw-r--r--meta/recipes-support/libexif/libexif_0.6.22.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/libexif/libexif_0.6.22.bb b/meta/recipes-support/libexif/libexif_0.6.22.bb
new file mode 100644
index 0000000000..a520d5c9f9
--- /dev/null
+++ b/meta/recipes-support/libexif/libexif_0.6.22.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2HOMEPAGE = "https://libexif.github.io/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
6
7def version_underscore(v):
8 return "_".join(v.split("."))
9
10SRC_URI = "https://github.com/libexif/libexif/releases/download/libexif-${@version_underscore("${PV}")}-release/libexif-${PV}.tar.xz \
11 "
12
13SRC_URI[sha256sum] = "5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56"
14
15UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
16
17inherit autotools gettext
18
19EXTRA_OECONF += "--disable-docs"