summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libevent/libevent_2.1.12.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-15 09:44:37 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-18 11:06:32 +0100
commit2fe17da211b1ccaf2d8130c861f35162efeaced6 (patch)
tree7b3832dd0bc4707af91a83e46a5b54d9d312fb49 /meta/recipes-support/libevent/libevent_2.1.12.bb
parent8e62e989f341e45e75124c3bef2ca4602378e740 (diff)
downloadpoky-2fe17da211b1ccaf2d8130c861f35162efeaced6.tar.gz
libevent: upgrade 2.1.11 -> 2.1.12
(From OE-Core rev: cb965ea3f191672c347e91e2ffb2586f119c77db) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libevent/libevent_2.1.12.bb')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.12.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.12.bb b/meta/recipes-support/libevent/libevent_2.1.12.bb
new file mode 100644
index 0000000000..29e87081d3
--- /dev/null
+++ b/meta/recipes-support/libevent/libevent_2.1.12.bb
@@ -0,0 +1,56 @@
1SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
10 file://Makefile-missing-test-dir.patch \
11 file://run-ptest \
12 file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \
13 "
14
15SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb"
16
17UPSTREAM_CHECK_URI = "http://libevent.org/"
18
19S = "${WORKDIR}/${BPN}-${PV}-stable"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
23
24inherit autotools
25
26# Needed for Debian packaging
27LEAD_SONAME = "libevent-2.1.so"
28
29inherit ptest multilib_header
30
31DEPENDS = "zlib"
32
33PACKAGES_DYNAMIC = "^${PN}-.*$"
34python split_libevent_libs () {
35 do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True)
36}
37PACKAGESPLITFUNCS_prepend = "split_libevent_libs "
38
39BBCLASSEXTEND = "native nativesdk"
40
41do_install_append() {
42 rm ${D}${bindir}/event_rpcgen.py
43 rmdir ${D}${bindir}
44 oe_multilib_header event2/event-config.h
45}
46
47do_install_ptest() {
48 install -d ${D}${PTEST_PATH}/test
49 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
50 do
51 install -m 0755 $file ${D}${PTEST_PATH}/test
52 done
53
54 # handle multilib
55 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
56}