diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2021-06-04 11:14:51 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-06-06 23:16:51 +0100 |
commit | d39cef3f8263334b8b9ff1b531fd5e963dfe715b (patch) | |
tree | 4339e22ac45faa00b80253ff78e711d98d70f02c /meta/recipes-support/libcap/libcap_2.50.bb | |
parent | c7b15f642b7a219dde771eee3a07bbe9b6e276d0 (diff) | |
download | poky-d39cef3f8263334b8b9ff1b531fd5e963dfe715b.tar.gz |
libcap: update 2.49 -> 2.50
(From OE-Core rev: 791d1a215400db08ef98193b2621ec02f108a302)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap/libcap_2.50.bb')
-rw-r--r-- | meta/recipes-support/libcap/libcap_2.50.bb | 73 |
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.50.bb b/meta/recipes-support/libcap/libcap_2.50.bb new file mode 100644 index 0000000000..15137f0ac0 --- /dev/null +++ b/meta/recipes-support/libcap/libcap_2.50.bb | |||
@@ -0,0 +1,73 @@ | |||
1 | SUMMARY = "Library for getting/setting POSIX.1e capabilities" | ||
2 | DESCRIPTION = "A library providing the API to access POSIX capabilities. \ | ||
3 | These allow giving various kinds of specific privileges to individual \ | ||
4 | users, without giving them full root permissions." | ||
5 | HOMEPAGE = "http://sites.google.com/site/fullycapable/" | ||
6 | # no specific GPL version required | ||
7 | LICENSE = "BSD | GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://License;md5=e2370ba375efe9e1a095c26d37e483b8" | ||
9 | |||
10 | DEPENDS = "hostperl-runtime-native gperf-native" | ||
11 | |||
12 | SRC_URI = "${KERNELORG_MIRROR}/linux/libs/security/linux-privs/${BPN}2/${BPN}-${PV}.tar.xz \ | ||
13 | file://0001-ensure-the-XATTR_NAME_CAPS-is-defined-when-it-is-use.patch \ | ||
14 | file://0002-tests-do-not-run-target-executables.patch \ | ||
15 | file://0001-tests-do-not-statically-link-a-test.patch \ | ||
16 | " | ||
17 | SRC_URI[sha256sum] = "47a57b8bd238b84c93c921a9b4ff82337551dbcb0cca071316aadf3e23b19261" | ||
18 | |||
19 | UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/linux/libs/security/linux-privs/${BPN}2/" | ||
20 | |||
21 | inherit lib_package | ||
22 | |||
23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" | ||
24 | PACKAGECONFIG_class-native ??= "" | ||
25 | |||
26 | PACKAGECONFIG[pam] = "PAM_CAP=yes,PAM_CAP=no,libpam" | ||
27 | |||
28 | EXTRA_OEMAKE = " \ | ||
29 | INDENT= \ | ||
30 | lib='${baselib}' \ | ||
31 | RAISE_SETFCAP=no \ | ||
32 | DYNAMIC=yes \ | ||
33 | BUILD_GPERF=yes \ | ||
34 | " | ||
35 | |||
36 | EXTRA_OEMAKE_append_class-target = " SYSTEM_HEADERS=${STAGING_INCDIR}" | ||
37 | |||
38 | do_compile() { | ||
39 | unset CFLAGS BUILD_CFLAGS | ||
40 | oe_runmake \ | ||
41 | ${PACKAGECONFIG_CONFARGS} \ | ||
42 | AR="${AR}" \ | ||
43 | CC="${CC}" \ | ||
44 | RANLIB="${RANLIB}" \ | ||
45 | COPTS="${CFLAGS}" \ | ||
46 | BUILD_COPTS="${BUILD_CFLAGS}" | ||
47 | } | ||
48 | |||
49 | do_install() { | ||
50 | oe_runmake install \ | ||
51 | ${PACKAGECONFIG_CONFARGS} \ | ||
52 | DESTDIR="${D}" \ | ||
53 | prefix="${prefix}" \ | ||
54 | SBINDIR="${sbindir}" | ||
55 | } | ||
56 | |||
57 | do_install_append() { | ||
58 | # Move the library to base_libdir | ||
59 | install -d ${D}${base_libdir} | ||
60 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then | ||
61 | mv ${D}${libdir}/libcap* ${D}${base_libdir} | ||
62 | if [ -d ${D}${libdir}/security ]; then | ||
63 | mv ${D}${libdir}/security ${D}${base_libdir} | ||
64 | fi | ||
65 | fi | ||
66 | } | ||
67 | |||
68 | FILES_${PN}-dev += "${base_libdir}/*.so" | ||
69 | |||
70 | # pam files | ||
71 | FILES_${PN} += "${base_libdir}/security/*.so" | ||
72 | |||
73 | BBCLASSEXTEND = "native nativesdk" | ||