summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-20 15:08:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-23 22:35:01 +0000
commitb567f5f59ec6b52b5aed5b6e74d10313e9c2ec2f (patch)
tree1ae060fbcb75b1ff8ca81849658edcae9865bf89 /meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
parente1767e1287ffcd207bb20b526d3673d0bde70e83 (diff)
downloadpoky-b567f5f59ec6b52b5aed5b6e74d10313e9c2ec2f.tar.gz
libcap-ng: Replace python patch with a better fix
By using the python3targetconfig class we can drop the existing python patch and the extra make parameters. (From OE-Core rev: 3bbebc39235f50af4d66e3284b67c1491d2c93f2) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
index 43f76dc561..6cea422d11 100644
--- a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
@@ -4,14 +4,13 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
4 4
5SUMMARY .= " - python" 5SUMMARY .= " - python"
6 6
7inherit lib_package autotools python3native 7inherit lib_package autotools python3targetconfig
8 8
9DEPENDS += "libcap-ng python3 swig-native" 9DEPENDS += "libcap-ng python3 swig-native"
10 10
11S = "${WORKDIR}/libcap-ng-${PV}" 11S = "${WORKDIR}/libcap-ng-${PV}"
12 12
13EXTRA_OECONF += "--with-python --with-python3" 13EXTRA_OECONF += "--with-python --with-python3"
14EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
15 14
16do_install_append() { 15do_install_append() {
17 rm -rf ${D}${bindir} 16 rm -rf ${D}${bindir}