summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2019-06-16 11:48:15 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-18 11:23:48 +0100
commitfa239aa7c1cf44f9a157cd47f4a355b596b00388 (patch)
tree2f5f11a3bbe0b5361aa2746e9ea36437ef3d9d5b /meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
parentf1a582bd0be0fb887729731126d83c469446cf95 (diff)
downloadpoky-fa239aa7c1cf44f9a157cd47f4a355b596b00388.tar.gz
libcap-ng: split into libcap-ng/libcap-ng-python
util-linux's setpriv needs the libcap-ng library but not the python package so split the package up to enable this without a dependency loop. (From OE-Core rev: 9592b318ccd6a8dca60d1060c8255ed8e62ef046) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
new file mode 100644
index 0000000000..e49b445f57
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.9.bb
@@ -0,0 +1,27 @@
1require libcap-ng.inc
2
3SUMMARY .= " - python"
4
5inherit lib_package autotools python3native
6
7DEPENDS += "libcap-ng python3 swig-native"
8
9S = "${WORKDIR}/libcap-ng-${PV}"
10
11EXTRA_OECONF += "--with-python --with-python3"
12EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
13
14do_install_append() {
15 rm -rf ${D}${bindir}
16 rm -rf ${D}${libdir}/.debug
17 rm -f ${D}${libdir}/lib*
18 rm -rf ${D}${libdir}/pkgconfig
19 rm -rf ${D}${datadir}
20 rm -rf ${D}${includedir}
21}
22
23# PACKAGES = "${PN}"
24
25FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
26FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
27