summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.8.2.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-02-10 14:18:24 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 22:33:39 +0000
commit72c6b6257fd98cf8f6a37e9f14b98a3a3844e5da (patch)
tree780bcb74f128d63abc6fc22ae5063d2ad66b2f88 /meta/recipes-support/libbsd/libbsd_0.8.2.bb
parent78be954e909a0260ec86671d41d9bc9e7b76b7f9 (diff)
downloadpoky-72c6b6257fd98cf8f6a37e9f14b98a3a3844e5da.tar.gz
libbsd: Security fix and update 0.8.2
This update includes: CVE-2016-2090 Heap buffer overflow in fgetwln function of libbsd libbsd 0.8.1 and earlier contains a buffer overflow in the function fgetwln(). An if checks if it is necessary to reallocate memory in the target buffer. However this check is off by one, therefore an out of bounds write happens. Upstream has released version 0.8.2 to fix this. (From OE-Core rev: 29053ff82bf28da45eef9d7e85d6d3ce7060daf6) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.8.2.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.8.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.8.2.bb b/meta/recipes-support/libbsd/libbsd_0.8.2.bb
new file mode 100644
index 0000000000..3335386d8f
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.8.2.bb
@@ -0,0 +1,43 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort
13# License: BSD-2-clause
14# License: BSD-2-clause
15# License: BSD-2-clause-NetBSD
16# License: BSD-2-clause-author
17# License: BSD-2-clause-verbatim
18# License: BSD-3-clause
19# License: BSD-3-clause
20# License: BSD-3-clause
21# License: BSD-3-clause-Peter-Wemm
22# License: BSD-3-clause-Regents
23# License: BSD-4-clause-Christopher-G-Demetriou
24# License: BSD-4-clause-Niels-Provos
25# License: BSD-5-clause-Peter-Wemm
26# License: Beerware
27# License: Expat
28# License: ISC
29# License: ISC-Original
30# License: public-domain
31# License: public-domain-Colin-Plumb
32LICENSE = "BSD-4-Clause & ISC & PD"
33LIC_FILES_CHKSUM = "file://COPYING;md5=145ec05a217d8f879f29cfc5f83084be"
34SECTION = "libs"
35
36SRC_URI = " \
37 http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
38"
39
40SRC_URI[md5sum] = "cdee252ccff978b50ad2336278c506c9"
41SRC_URI[sha256sum] = "b2f644cae94a6e2fe109449c20ad79a0f6ee4faec2205b07eefa0020565e250a"
42
43inherit autotools pkgconfig