summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.12.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-26 08:34:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:02 +0100
commit91d938c81f665b7a5bf3358f534bfb90958d9d71 (patch)
tree6ccd471ba49e72476e84e9e67ce506e806743e00 /meta/recipes-support/libbsd/libbsd_0.12.2.bb
parent0a7baeea29c31c42f01fce78d2ac7aa1caa709fe (diff)
downloadpoky-91d938c81f665b7a5bf3358f534bfb90958d9d71.tar.gz
libbsd: upgrade 0.12.1 -> 0.12.2
Changelog: ============ -test: nlist: make resilient against -Wl,--gc-sections -build: Do not rely on internal autoconf ac_cv_sys_file_offset_bits variable -build: Use -eq instead of = as test operators for arithmetic tests -build: Fix typo in ABI selection description -build: Only install time struct conversion macros where missing -man: Add links for errc module functions -man: Do not install timeval(3bsd) nor timespec(3bsd) -strtonum: Do not abort on EINVAL from strtoi() -closefrom: Ignore files starting with dot when scanning /proc/self/fd -build: Match also gnu* for GNU/Hurd on the glibc ABI selection (From OE-Core rev: f8df6066c8d9efd1c85c6d5f2c306da06faad860) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.12.2.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.12.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.12.2.bb b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
new file mode 100644
index 0000000000..7d5e88f293
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Library of utility functions from BSD systems"
2DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
3 and lacking on others like GNU systems, thus making it easier to port \
4 projects with strong BSD origins, without needing to embed the same \
5 code over and over again on each project."
6
7HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
8# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
9# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
10# License: BSD-2-clause
11# License: BSD-2-clause-NetBSD
12# License: BSD-2-clause-author
13# License: BSD-2-clause-verbatim
14# License: BSD-3-clause
15# License: BSD-3-clause-author
16# License: BSD-3-clause-John-Birrell
17# License: BSD-3-clause-Regents
18# License: BSD-4-clause-Christopher-G-Demetriou
19# License: BSD-4-clause-Niels-Provos
20# License: BSD-5-clause-Peter-Wemm
21# License: Beerware
22# License: Expat
23# License: ISC
24# License: ISC-Original
25# License: public-domain
26# License: public-domain-Colin-Plumb
27LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
28LICENSE:${PN} = "BSD-3-Clause & ISC & PD"
29LICENSE:${PN}-dbg = "BSD-3-Clause & ISC & PD"
30LICENSE:${PN}-dev = "BSD-3-Clause & ISC & PD"
31LICENSE:${PN}-doc = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
32LICENSE:${PN}-locale = "BSD-3-Clause & ISC & PD"
33LICENSE:${PN}-src = "BSD-3-Clause & ISC & PD"
34LICENSE:${PN}-staticdev = "BSD-3-Clause & ISC & PD"
35
36LIC_FILES_CHKSUM = "file://COPYING;md5=9b087a0981a1fcad42efbba6d4925a0f"
37SECTION = "libs"
38
39SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
40
41SRC_URI[sha256sum] = "b88cc9163d0c652aaf39a99991d974ddba1c3a9711db8f1b5838af2a14731014"
42
43inherit autotools pkgconfig
44
45DEPENDS += "libmd"
46
47BBCLASSEXTEND = "native nativesdk"