summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu/icu_59.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-07-24 17:28:08 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-27 22:36:53 +0100
commit9dd27d796326a4e0f48d3d277ffafb78ba4e53f1 (patch)
tree16f7262766fef20379aa1e6bcf97d4424e157301 /meta/recipes-support/icu/icu_59.1.bb
parentff736d8d613a492bb77dd88a49e6d686ce6c07aa (diff)
downloadpoky-9dd27d796326a4e0f48d3d277ffafb78ba4e53f1.tar.gz
icu: update to 59.1
License checksum change due to copyright year update. Latest icu will not compile with anything less than C++11, so drop the enforcement of an earlier C++ version. This should be okay, as there is now a fix in place for the problem of mixing native gcc 4/5 compiled code: http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=c21cec84886d9c70396e9be0ceb9a8ef300b54be (From OE-Core rev: b002f44ed5a07b42deb8cccdb192e12091cd654f) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu/icu_59.1.bb')
-rw-r--r--meta/recipes-support/icu/icu_59.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/icu_59.1.bb b/meta/recipes-support/icu/icu_59.1.bb
new file mode 100644
index 0000000000..31f017b370
--- /dev/null
+++ b/meta/recipes-support/icu/icu_59.1.bb
@@ -0,0 +1,29 @@
1require icu.inc
2
3LIC_FILES_CHKSUM = "file://../LICENSE;md5=fe9e1f2c500466d8f18df2cd068e4b74"
4
5def icu_download_version(d):
6 pvsplit = d.getVar('PV').split('.')
7 return pvsplit[0] + "_" + pvsplit[1]
8
9ICU_PV = "${@icu_download_version(d)}"
10
11# http://errors.yoctoproject.org/Errors/Details/20486/
12ARM_INSTRUCTION_SET_armv4 = "arm"
13ARM_INSTRUCTION_SET_armv5 = "arm"
14
15BASE_SRC_URI = "http://download.icu-project.org/files/icu4c/${PV}/icu4c-${ICU_PV}-src.tgz"
16SRC_URI = "${BASE_SRC_URI} \
17 file://icu-pkgdata-large-cmd.patch \
18 file://fix-install-manx.patch \
19 file://0001-i18n-Drop-include-xlocale.h.patch \
20 "
21
22SRC_URI_append_class-target = "\
23 file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
24 "
25SRC_URI[md5sum] = "54923fa9fab5b2b83f235fb72523de37"
26SRC_URI[sha256sum] = "7132fdaf9379429d004005217f10e00b7d2319d0fea22bdfddef8991c45b75fe"
27
28UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
29UPSTREAM_CHECK_URI = "http://download.icu-project.org/files/icu4c/"