summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls/gnutls_3.7.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-28 21:04:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 11:53:26 +0000
commit9df2b1b5a9e3b3b176a5e5289df45c7127245c33 (patch)
tree2a0f90a88f6e7772caa69f6a14ab804e8af4d570 /meta/recipes-support/gnutls/gnutls_3.7.0.bb
parent14a97e0cdb18125e841e5a767f30cc297f94da9a (diff)
downloadpoky-9df2b1b5a9e3b3b176a5e5289df45c7127245c33.tar.gz
gnutls: update 3.6.15 -> 3.7.0
(From OE-Core rev: 6c4b2dcf82378419efca587f033ecac08fbc3b00) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_3.7.0.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.7.0.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_3.7.0.bb b/meta/recipes-support/gnutls/gnutls_3.7.0.bb
new file mode 100644
index 0000000000..e3ca86b933
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls_3.7.0.bb
@@ -0,0 +1,67 @@
1SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
22 "
23
24SRC_URI[sha256sum] = "49e2a22691d252c9f24a9829b293a8f359095bc5a818351f05f1c0a5188a1df8"
25
26inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
27
28PACKAGECONFIG ??= "libidn"
29
30# You must also have CONFIG_SECCOMP enabled in the kernel for
31# seccomp to work.
32PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
33PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
34PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
35PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
36PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
37
38EXTRA_OECONF = " \
39 --enable-doc \
40 --disable-libdane \
41 --disable-guile \
42 --disable-rpath \
43 --enable-local-libopts \
44 --enable-openssl-compatibility \
45 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
46 --with-librt-prefix=${STAGING_DIR_HOST}${prefix} \
47 --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \
48"
49
50# Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell.
51export POSIX_SHELL="${base_bindir}/sh"
52
53LDFLAGS_append_libc-musl = " -largp"
54
55do_configure_prepend() {
56 for dir in . lib; do
57 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
58 done
59}
60
61PACKAGES =+ "${PN}-openssl ${PN}-xx"
62
63FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
64FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
65FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
66
67BBCLASSEXTEND = "native nativesdk"