summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.2.9.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-11-09 17:07:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:39 +0000
commitec206ffe9eb0a45380d4c8d4d1ad9c69a32db9d3 (patch)
tree4c4125ec1542d1824c8da347fbe34987686e89a2 /meta/recipes-support/gnupg/gnupg_2.2.9.bb
parent14898aa4750f13bbfa4c9c7719bcdeb5f7f457c5 (diff)
downloadpoky-ec206ffe9eb0a45380d4c8d4d1ad9c69a32db9d3.tar.gz
gnupg: upgrade 2.2.9 -> 2.2.10
(From OE-Core rev: 5efe9eb79ac325f55fc52f67b522afaf7ebb847a) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.2.9.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.9.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.9.bb b/meta/recipes-support/gnupg/gnupg_2.2.9.bb
deleted file mode 100644
index b7d23b8d39..0000000000
--- a/meta/recipes-support/gnupg/gnupg_2.2.9.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 "
18SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
19 file://relocate.patch"
20
21
22SRC_URI[md5sum] = "52c895a81f514a65e08923736c38654a"
23SRC_URI[sha256sum] = "6278eaabffa1ebc9fa2ceb3dc53eea9a1505ab02a668a86dd6fec06951af2164"
24
25EXTRA_OECONF = "--disable-ldap \
26 --disable-ccid-driver \
27 --with-zlib=${STAGING_LIBDIR}/.. \
28 --with-bzip2=${STAGING_LIBDIR}/.. \
29 --with-readline=${STAGING_LIBDIR}/.. \
30 --enable-gpg-is-gpg2 \
31 "
32RRECOMMENDS_${PN} = "pinentry"
33
34do_configure_prepend () {
35 # Else these could be used in prefernce to those in aclocal-copy
36 rm -f ${S}/m4/gpg-error.m4
37 rm -f ${S}/m4/libassuan.m4
38 rm -f ${S}/m4/ksba.m4
39 rm -f ${S}/m4/libgcrypt.m4
40}
41
42do_install_append() {
43 ln -sf gpg2 ${D}${bindir}/gpg
44 ln -sf gpgv2 ${D}${bindir}/gpgv
45}
46
47do_install_append_class-native() {
48 create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
49}
50
51PACKAGECONFIG ??= "gnutls"
52PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
53PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
54
55BBCLASSEXTEND = "native"