summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.23.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-02-08 16:25:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-10 10:32:08 +0000
commit7aab974f7f6b8d2ebba50a29bf98b58672d6330d (patch)
treec7315dacf3758d5d479db549837213f1ab30c74d /meta/recipes-support/gdbm/gdbm_1.23.bb
parent6939cb68fcd77d19ac3801f29038f276f163f065 (diff)
downloadpoky-7aab974f7f6b8d2ebba50a29bf98b58672d6330d.tar.gz
gdbm: upgrade 1.22 -> 1.23
refresh ptest.patch (From OE-Core rev: 38d0c34b6a1b44fcc41099936b534202111c3ef7) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.23.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.23.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.23.bb b/meta/recipes-support/gdbm/gdbm_1.23.bb
new file mode 100644
index 0000000000..4ec80b5b7e
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.23.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Key/value database library with extensible hashing"
2DESCRIPTION = "Library of database functions that use extensible hashing \
3and work similar to the standard UNIX dbm. These routines are provided \
4to a programmer needing to create and manipulate a hashed database."
5HOMEPAGE = "http://www.gnu.org/software/gdbm/"
6SECTION = "libs"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
9
10
11SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
12 file://run-ptest \
13 file://ptest.patch \
14 "
15
16SRC_URI[sha256sum] = "74b1081d21fff13ae4bd7c16e5d6e504a4c26f7cde1dca0d963a484174bbcacd"
17
18inherit autotools gettext texinfo lib_package ptest
19
20# Needed for dbm python module
21EXTRA_OECONF = "--enable-libgdbm-compat --without-readline"
22
23# Stop presence of dbm/nbdm on the host contaminating builds
24CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
25
26BBCLASSEXTEND = "native nativesdk"
27
28do_install:append () {
29 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
30 # these headers
31 install -d ${D}${includedir}/gdbm
32 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
33 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
34}
35
36RDEPENDS:${PN}-ptest += "diffutils ${PN}-bin"
37
38do_compile_ptest() {
39 oe_runmake -C tests buildtests
40}
41
42PACKAGES =+ "${PN}-compat \
43 "
44FILES:${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
45 "