summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.19.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2021-01-05 15:38:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-08 10:10:15 +0000
commitcdf2be3746ce54141a761bda6fdc9ae9c44d5964 (patch)
tree27b0884a28b66652a7923966539b387110dfd992 /meta/recipes-support/gdbm/gdbm_1.19.bb
parent52dcec880fbf8156f88ffc1793875af28ac758c1 (diff)
downloadpoky-cdf2be3746ce54141a761bda6fdc9ae9c44d5964.tar.gz
gdbm: upgrade 1.18.1 -> 1.19
gdbm-fix-link-failure-against-gcc-10.patch Removed since this is included in 1.19 (From OE-Core rev: d96bb907652bd83abc1386555a93678dd64ced4f) Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.19.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.19.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.19.bb b/meta/recipes-support/gdbm/gdbm_1.19.bb
new file mode 100644
index 0000000000..1f390a4aa2
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.19.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
11 "
12
13SRC_URI[md5sum] = "aeb29c6a90350a4c959cd1df38cd0a7e"
14SRC_URI[sha256sum] = "37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc"
15
16inherit autotools gettext texinfo lib_package ptest
17
18# Needed for dbm python module
19EXTRA_OECONF = "--enable-libgdbm-compat --without-readline"
20
21# Stop presence of dbm/nbdm on the host contaminating builds
22CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
23
24BBCLASSEXTEND = "native nativesdk"
25
26do_install_append () {
27 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
28 # these headers
29 install -d ${D}${includedir}/gdbm
30 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
31 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
32}
33
34RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
35
36do_compile_ptest() {
37 oe_runmake -C tests buildtests
38}
39
40PACKAGES =+ "${PN}-compat \
41 "
42FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
43 "