summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.14.1.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-01-18 10:26:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-23 23:43:45 +0000
commit89f061fb5bef0b506b4e65ad6664f64b88f18c4c (patch)
treeeeb1a77a44d689f458de882e0d97700b3523ece1 /meta/recipes-support/gdbm/gdbm_1.14.1.bb
parent902b77bf91d96517b935bce00a11003604dc3d54 (diff)
downloadpoky-89f061fb5bef0b506b4e65ad6664f64b88f18c4c.tar.gz
gdbm: 1.13 -> 1.14.1
Upgrade gdbm from 1.13 to 1.14.1. (From OE-Core rev: cede695564b1ac9e3513ac592aa43f695e6e00f0) (From OE-Core rev: c01f12faaf8347cb193776fedac3401775b3bbe7) Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.14.1.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.14.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.14.1.bb b/meta/recipes-support/gdbm/gdbm_1.14.1.bb
new file mode 100644
index 0000000000..54e5696e42
--- /dev/null
+++ b/meta/recipes-support/gdbm/gdbm_1.14.1.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
11 "
12
13SRC_URI[md5sum] = "c2ddcb3897efa0f57484af2bd4f4f848"
14SRC_URI[sha256sum] = "cdceff00ffe014495bed3aed71c7910aa88bf29379f795abc0f46d4ee5f8bc5f"
15
16inherit autotools gettext texinfo lib_package ptest
17
18# Needed for dbm python module
19EXTRA_OECONF = "-enable-libgdbm-compat"
20
21# Stop presence of dbm/nbdm on the host contaminating builds
22CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
23
24BBCLASSEXTEND = "native nativesdk"
25
26do_install_append () {
27 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
28 # these headers
29 install -d ${D}${includedir}/gdbm
30 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
31 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
32}
33
34RDEPENDS_${PN}-ptest += "diffutils"
35
36do_compile_ptest() {
37 oe_runmake -C tests buildtests
38}
39
40PACKAGES =+ "${PN}-compat \
41 "
42FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
43 "