summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope/diffoscope_265.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-24 16:41:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 10:06:02 +0100
commit929f60bdcc287c683101392419160c73c9d2797b (patch)
treef5863846810c24e709543caa6c8387013808acf3 /meta/recipes-support/diffoscope/diffoscope_265.bb
parente6f70e0f83e4441ebae8c97bae05f4f386011e29 (diff)
downloadpoky-929f60bdcc287c683101392419160c73c9d2797b.tar.gz
diffoscope: upgrade 260 -> 265
Changelog: ========== * Ensure that tests with ">=" version constraints actually print the corresponding tool name. * Prevent odt2txt tests from always being skipped due to an impossibly new version requirement. * Avoid nested parens-in-parens when printing "skipping" messages in the testsuite. * Don't crash on invalid zipfiles, even if we encounter 'badness' halfway through the file. * Fix a crash when there are (invalid) duplicate entries in .zip files. * Add note when there are duplicate entries in ZIP files. * Add an external tool reference for GNU Guix for zipdetails. * Add support for the zipdetails(1) tool included in the Perl distribution. * Don't use parenthesis within test "skipping" messages; PyTest adds its own parenthesis, so we were ending up with double nested parens. * Fix the .epub tests after supporting zipdetails(1). * Update copyright years and debian/tests/control. * Fix MozillaZipContainer's monkeypatch after Python's zipfile module changed to detect potentially insecure overlapping entries within .zip files. * Factor out Python version checking in test_zip.py. * Also skip some zip tests under 3.10.14 as well; a potential regression may have been backported to the 3.10.x series. The underlying cause is still to be investigated. * Don't crash if we encounter an .rdb file without an equivalent .rdx file. * In addition, don't identify Redis database dumps (etc.) as GNU R database files based simply on their filename. (From OE-Core rev: f22945ba9b4835e52809bedc4e3be73a91aafe07) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/diffoscope/diffoscope_265.bb')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_265.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_265.bb b/meta/recipes-support/diffoscope/diffoscope_265.bb
new file mode 100644
index 0000000000..6af5abc974
--- /dev/null
+++ b/meta/recipes-support/diffoscope/diffoscope_265.bb
@@ -0,0 +1,43 @@
1SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "7bdcbd7fc5bc4c821bf6ab5ffbbeb265103b04e6908ea4bb12144d7e5ca002ff"
16
17RDEPENDS:${PN} += "\
18 binutils \
19 python3-curses \
20 python3-difflib \
21 python3-fcntl \
22 python3-json \
23 python3-libarchive-c \
24 python3-magic \
25 python3-multiprocessing \
26 python3-pprint \
27 python3-rpm \
28 squashfs-tools \
29 vim \
30 "
31
32# Dependencies don't build for musl
33COMPATIBLE_HOST:libc-musl = 'null'
34
35do_install:append:class-native() {
36 create_wrapper ${D}${bindir}/diffoscope \
37 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
38 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
39 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
40 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
41}
42
43BBCLASSEXTEND = "native"