summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope/diffoscope_206.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-03-08 10:32:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-09 11:46:27 +0000
commitd662b6f152e0f7f8088f1d8d8921cb72661c7dac (patch)
tree0ddd4d74a0af4c3d207f2252c69000c2422975e0 /meta/recipes-support/diffoscope/diffoscope_206.bb
parentf2aeaa4848c9d334d56cb96a06a264b7274f9aa5 (diff)
downloadpoky-d662b6f152e0f7f8088f1d8d8921cb72661c7dac.tar.gz
diffoscope: upgrade 204 -> 206
(From OE-Core rev: ef6421463a2d5748474016d6ca4c299d6cf78dbe) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/diffoscope/diffoscope_206.bb')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_206.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_206.bb b/meta/recipes-support/diffoscope/diffoscope_206.bb
new file mode 100644
index 0000000000..7eaca74b33
--- /dev/null
+++ b/meta/recipes-support/diffoscope/diffoscope_206.bb
@@ -0,0 +1,30 @@
1SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "93731939ede57547a3275c3c81875ab4bd222f26364a7519cf6aafe1939cd603"
16
17RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
18
19# Dependencies don't build for musl
20COMPATIBLE_HOST:libc-musl = 'null'
21
22do_install:append:class-native() {
23 create_wrapper ${D}${bindir}/diffoscope \
24 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
25 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
26 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
27 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
28}
29
30BBCLASSEXTEND = "native"