summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope/diffoscope_168.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 00:07:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 00:17:46 +0000
commitfc222345f071b845f65a4ce382fe64d681c48df5 (patch)
tree925244e361254c356e26cbcd735f7dfc46d73dc5 /meta/recipes-support/diffoscope/diffoscope_168.bb
parent09301e305122f0957f8d748bfe4cbe22389ce5d0 (diff)
downloadpoky-fc222345f071b845f65a4ce382fe64d681c48df5.tar.gz
diffoscope: Upgrade 167 -> 168
This includes a fix for the 'hang' on larger diffs with html output as seen on the autobuilder. (From OE-Core rev: cac4ed44b302a3effd0ed6729cbf65817824604e) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/diffoscope/diffoscope_168.bb')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_168.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_168.bb b/meta/recipes-support/diffoscope/diffoscope_168.bb
new file mode 100644
index 0000000000..9d112d2ce8
--- /dev/null
+++ b/meta/recipes-support/diffoscope/diffoscope_168.bb
@@ -0,0 +1,24 @@
1SUMMARY = "in-depth comparison of files, archives, and directories"
2HOMEPAGE = "https://diffoscope.org/"
3LICENSE = "GPL-3.0+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6PYPI_PACKAGE = "diffoscope"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "c6f1dc3e75b7e2e5ceac4f857fbd2ee0ddb3f0169c2b39ea9187af34208e98de"
11
12RDEPENDS_${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
13
14# Dependencies don't build for musl
15COMPATIBLE_HOST_libc-musl = 'null'
16
17do_install_append_class-native() {
18 create_wrapper ${D}${bindir}/diffoscope \
19 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
20 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
21 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
22}
23
24BBCLASSEXTEND = "native"