summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.8.6.1.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-02-22 09:55:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 10:43:07 +0000
commitf16eee49469295eed7fbdafa738c60fe63c57e40 (patch)
tree5b11284bba11ee458a262f71ec287ea06818385e /meta/recipes-support/debianutils/debianutils_4.8.6.1.bb
parent86be661fd6ae90abc5108c7cba56bdcefa812eab (diff)
downloadpoky-f16eee49469295eed7fbdafa738c60fe63c57e40.tar.gz
debianutils: update to 4.8.6.1
(From OE-Core rev: a0e8cdd7256cf1f000f5338b010f5f1f9149dab0) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.8.6.1.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.8.6.1.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.8.6.1.bb b/meta/recipes-support/debianutils/debianutils_4.8.6.1.bb
new file mode 100644
index 0000000000..7cc78a6850
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_4.8.6.1.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20190217T160716Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[md5sum] = "80e2e670d8f6c0036770e971237f1f5c"
12SRC_URI[sha256sum] = "099f1e8a7278b26145a2ba2dda84c4118403bfab38c8d7070a6235a7ffcb55ed"
13
14S = "${WORKDIR}/${BPN}"
15
16inherit autotools update-alternatives
17
18do_configure_prepend() {
19 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
20}
21
22do_install_append() {
23 if [ "${base_bindir}" != "${bindir}" ]; then
24 # Debian places some utils into ${base_bindir} as does busybox
25 install -d ${D}${base_bindir}
26 for app in run-parts tempfile; do
27 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
28 done
29 fi
30}
31
32# Note that we package the update-alternatives name.
33#
34PACKAGES =+ "${PN}-run-parts"
35FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
36
37RDEPENDS_${PN} += "${PN}-run-parts"
38RDEPENDS_${PN}_class-native = ""
39
40ALTERNATIVE_PRIORITY="30"
41ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
42
43ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
44ALTERNATIVE_${PN}-run-parts = "run-parts"
45
46ALTERNATIVE_${PN}-doc = "which.1"
47ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
48
49ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
50ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
51ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
52ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
53ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
54ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
55ALTERNATIVE_LINK_NAME[which]="${bindir}/which"
56
57BBCLASSEXTEND = "native"