summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.8.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-12-20 22:17:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-05 13:54:05 +0000
commitfde38fe8db8cefac2c894d8837c683bb570c8f0f (patch)
tree00c8436084bb61e7c8df0f07ecf483c7b6e029f1 /meta/recipes-support/debianutils/debianutils_4.8.1.bb
parent6dbfeb5ef3ff27b1fc52f93fea8c38b584f242a2 (diff)
downloadpoky-fde38fe8db8cefac2c894d8837c683bb570c8f0f.tar.gz
debianutils: 4.8 -> 4.8.1
(From OE-Core rev: dfd4c078a38c3df9ac91ae3e8d01787611bb8cab) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.8.1.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.8.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.8.1.bb b/meta/recipes-support/debianutils/debianutils_4.8.1.bb
new file mode 100644
index 0000000000..54c74e097c
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_4.8.1.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20161118T033019Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11
12SRC_URI[md5sum] = "44083fc66164746880dffd30d62d054b"
13SRC_URI[sha256sum] = "2c395c0bdcfe89de30828b1d25cc5549ded5225a6d3625fbcb2cc0881ef5f026"
14
15inherit autotools update-alternatives
16
17do_configure_prepend() {
18 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
19}
20
21do_install_append() {
22 if [ "${base_bindir}" != "${bindir}" ]; then
23 # Debian places some utils into ${base_bindir} as does busybox
24 install -d ${D}${base_bindir}
25 for app in run-parts tempfile; do
26 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
27 done
28 fi
29}
30
31# Note that we package the update-alternatives name.
32#
33PACKAGES =+ "${PN}-run-parts"
34FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
35
36RDEPENDS_${PN} += "${PN}-run-parts"
37
38
39ALTERNATIVE_PRIORITY="30"
40ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
41ALTERNATIVE_${PN}-run-parts = "run-parts"
42
43ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
44ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
45ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
46ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
47ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
48ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
49ALTERNATIVE_LINK_NAME[which]="${bindir}/which"