summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.11.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-12-15 23:40:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-17 09:56:14 +0000
commit7bfe7e036eccd3da2c64954b87656774ae9c161f (patch)
tree190fa06691a7f957ccba81ef526bf947f1b6536b /meta/recipes-support/debianutils/debianutils_4.11.2.bb
parente326f0da6b0769eda16a0cabc2185931902ef3b9 (diff)
downloadpoky-7bfe7e036eccd3da2c64954b87656774ae9c161f.tar.gz
debianutils: update 4.11.2 -> 5.5
(From OE-Core rev: 742042ca1a3d0bbb9736513cf2c9629221c8d84b) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.11.2.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.11.2.bb60
1 files changed, 0 insertions, 60 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.11.2.bb b/meta/recipes-support/debianutils/debianutils_4.11.2.bb
deleted file mode 100644
index 231666c4dc..0000000000
--- a/meta/recipes-support/debianutils/debianutils_4.11.2.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2DESCRIPTION = "Provides a number of small utilities which are used \
3primarily by the installation scripts of Debian packages, although \
4you may use them directly. "
5HOMEPAGE = "https://packages.debian.org/sid/debianutils"
6BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable"
7SECTION = "base"
8LICENSE = "GPLv2 & SMAIL_GPL"
9LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94"
10
11SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
12# the package is taken from snapshots.debian.org; that source is static and goes stale
13# so we check the latest upstream from a directory that does get updated
14UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
15
16SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de"
17
18inherit autotools update-alternatives
19
20S = "${WORKDIR}/debianutils"
21do_configure:prepend() {
22 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
23}
24
25do_install:append() {
26 if [ "${base_bindir}" != "${bindir}" ]; then
27 # Debian places some utils into ${base_bindir} as does busybox
28 install -d ${D}${base_bindir}
29 for app in run-parts tempfile; do
30 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
31 done
32 fi
33}
34
35# Note that we package the update-alternatives name.
36#
37PACKAGES =+ "${PN}-run-parts"
38FILES:${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
39
40RDEPENDS:${PN} += "${PN}-run-parts"
41RDEPENDS:${PN}:class-native = ""
42
43ALTERNATIVE_PRIORITY = "30"
44ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog tempfile which"
45
46ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
47ALTERNATIVE:${PN}-run-parts = "run-parts"
48
49ALTERNATIVE:${PN}-doc = "which.1"
50ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
51
52ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
53ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
54ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
55ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
56ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
57ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile"
58ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
59
60BBCLASSEXTEND = "native"