summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-support/db/db_5.3.28.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index b2ae98f05c..d5b788a3d7 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -13,7 +13,7 @@ SUMMARY = "Berkeley Database v5"
13DESCRIPTION = "Provides the foundational storage services for your application, no matter how demanding and unique your requirements may seem to be" 13DESCRIPTION = "Provides the foundational storage services for your application, no matter how demanding and unique your requirements may seem to be"
14HOMEPAGE = "https://www.oracle.com/database/technologies/related/berkeleydb.html" 14HOMEPAGE = "https://www.oracle.com/database/technologies/related/berkeleydb.html"
15LICENSE = "Sleepycat" 15LICENSE = "Sleepycat"
16RCONFLICTS_${PN} = "db3" 16RCONFLICTS:${PN} = "db3"
17 17
18CVE_PRODUCT = "oracle_berkeley_db berkeley_db" 18CVE_PRODUCT = "oracle_berkeley_db berkeley_db"
19CVE_VERSION = "11.2.${PV}" 19CVE_VERSION = "11.2.${PV}"
@@ -47,7 +47,7 @@ inherit autotools
47inherit lib_package 47inherit lib_package
48 48
49PACKAGES =+ "${PN}-cxx" 49PACKAGES =+ "${PN}-cxx"
50FILES_${PN}-cxx = "${libdir}/*cxx*so" 50FILES:${PN}-cxx = "${libdir}/*cxx*so"
51 51
52# The dev package has the .so link (as in db3) and the .a's - 52# The dev package has the .so link (as in db3) and the .a's -
53# it is therefore incompatible (cannot be installed at the 53# it is therefore incompatible (cannot be installed at the
@@ -75,7 +75,7 @@ AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
75# configure. 75# configure.
76CONFIG_SITE = "" 76CONFIG_SITE = ""
77 77
78oe_runconf_prepend() { 78oe_runconf:prepend() {
79 . ${S}/dist/RELEASE 79 . ${S}/dist/RELEASE
80 # Edit version information we couldn't pre-compute. 80 # Edit version information we couldn't pre-compute.
81 sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \ 81 sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \
@@ -89,12 +89,12 @@ oe_runconf_prepend() {
89 -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure 89 -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure
90} 90}
91 91
92do_compile_prepend() { 92do_compile:prepend() {
93 # Stop libtool adding RPATHs 93 # Stop libtool adding RPATHs
94 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool 94 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool
95} 95}
96 96
97do_install_append() { 97do_install:append() {
98 mkdir -p ${D}/${includedir}/db51 98 mkdir -p ${D}/${includedir}/db51
99 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/. 99 mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/.
100 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/. 100 mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/.
@@ -115,7 +115,7 @@ do_install_append() {
115 fi 115 fi
116} 116}
117 117
118INSANE_SKIP_${PN} = "dev-so" 118INSANE_SKIP:${PN} = "dev-so"
119INSANE_SKIP_${PN}-cxx = "dev-so" 119INSANE_SKIP:${PN}-cxx = "dev-so"
120 120
121BBCLASSEXTEND = "native nativesdk" 121BBCLASSEXTEND = "native nativesdk"