summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-01 13:52:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-08 22:24:03 +0000
commit55d97536399c83d61365fd60f3d0e117c20564d3 (patch)
tree75e9ca5a19f4d720048f62329a47cd7feb317eea /meta/recipes-support/db/db_5.3.28.bb
parentf54f556284267241073250248208731474a8d220 (diff)
downloadpoky-55d97536399c83d61365fd60f3d0e117c20564d3.tar.gz
db: change types to avoid headers changing between architectures
Triggered by looking at why Python doesn't find db.h (because it greps db.h for a regex, and db.h is actually a oe_multilib_header wrapper) I realised that the only reason we have to oe_multilib_header db.h is because one typedef is different between 32-bit and 64-bit architectures. However, the typedef is for a 64-bit integer so instead of using long (64-bit) or long long (32-bit), just use int64_t. Some of the overly complicated configure tests need to be deleted after this change but that is safe as we're building in a controlled environment and can assume int64_t exists. With this done the header doesn't change between architectures, and it doesn't need to be wrapped by oe_multilib_header. (From OE-Core rev: 60aa20b8b691e5a72a6a11bf795b86c6359db886) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index 66282600f5..fb4befbaf7 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -23,6 +23,7 @@ SRC_URI += "file://arm-thumb-mutex_db5.patch \
23 file://fix-parallel-build.patch \ 23 file://fix-parallel-build.patch \
24 file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \ 24 file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \
25 file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \ 25 file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \
26 file://sequence-type.patch \
26 " 27 "
27# We are not interested in official latest 6.x versions; 28# We are not interested in official latest 6.x versions;
28# let's track what debian is using. 29# let's track what debian is using.
@@ -34,7 +35,7 @@ SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe7247804317
34 35
35LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955" 36LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955"
36 37
37inherit autotools multilib_header 38inherit autotools
38 39
39# Put virtual/db in any appropriate provider of a 40# Put virtual/db in any appropriate provider of a
40# relational database, use it as a dependency in 41# relational database, use it as a dependency in
@@ -112,8 +113,6 @@ do_install_append() {
112 ln -s db51/db.h ${D}/${includedir}/db.h 113 ln -s db51/db.h ${D}/${includedir}/db.h
113 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h 114 ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
114 115
115 oe_multilib_header db51/db.h
116
117 # The docs end up in /usr/docs - not right. 116 # The docs end up in /usr/docs - not right.
118 if test -d "${D}/${prefix}/docs" 117 if test -d "${D}/${prefix}/docs"
119 then 118 then