summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-23 14:05:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-10 14:12:17 +0100
commit3a6f0b66a5550b392317c6ad77a4e8298906d218 (patch)
tree2b288a9061f6dd424c3365b111d0401ee9ad2df2 /meta/recipes-support/db/db_5.3.28.bb
parentb58c5dc787227aaf069f812450ff366608097099 (diff)
downloadpoky-3a6f0b66a5550b392317c6ad77a4e8298906d218.tar.gz
db: use S/B more idiomatically
Instead of setting S to a directory inside the tarball and B to another directory inside the tarball, use the default value of S and set AUTOTOOLS_SCRIPT_PATH to the right path to find configure. Update the patches so they still apply, and clean up the recipe slightly. Because something is not quite right regarding quilt and patching, add a PR bump to the recipes to ensure that a clean work directory is used: for some reason rebuilds will rarely fail to patch correctly. (From OE-Core rev: dcbef72b8344c22617d65ea1e9f0fa7ad9a742bd) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb28
1 files changed, 11 insertions, 17 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index c724f049f7..6b0e76b1a3 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -15,15 +15,17 @@ LICENSE = "Sleepycat"
15VIRTUAL_NAME ?= "virtual/db" 15VIRTUAL_NAME ?= "virtual/db"
16RCONFLICTS_${PN} = "db3" 16RCONFLICTS_${PN} = "db3"
17 17
18PR = "r1"
19
18SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz" 20SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
19SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \ 21SRC_URI += "file://arm-thumb-mutex_db5.patch \
20 file://fix-parallel-build.patch \ 22 file://fix-parallel-build.patch \
21 " 23 "
22 24
23SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24" 25SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24"
24SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628" 26SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628"
25 27
26LIC_FILES_CHKSUM = "file://../LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955" 28LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955"
27 29
28inherit autotools 30inherit autotools
29 31
@@ -36,14 +38,6 @@ inherit autotools
36# to select the correct db in the build (distro) .conf 38# to select the correct db in the build (distro) .conf
37PROVIDES += "${VIRTUAL_NAME}" 39PROVIDES += "${VIRTUAL_NAME}"
38 40
39# bitbake isn't quite clever enough to deal with sleepycat,
40# the distribution sits in the expected directory, but all
41# the builds must occur from a sub-directory. The following
42# persuades bitbake to go to the right place
43S = "${WORKDIR}/db-${PV}/dist"
44B = "${WORKDIR}/db-${PV}/build_unix"
45SPDX_S = "${WORKDIR}/db-${PV}"
46
47# The executables go in a separate package - typically there 41# The executables go in a separate package - typically there
48# is no need to install these unless doing real database 42# is no need to install these unless doing real database
49# management on the system. 43# management on the system.
@@ -75,21 +69,22 @@ ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
75MUTEX = "" 69MUTEX = ""
76MUTEX_arm = "${ARM_MUTEX}" 70MUTEX_arm = "${ARM_MUTEX}"
77MUTEX_armeb = "${ARM_MUTEX}" 71MUTEX_armeb = "${ARM_MUTEX}"
78EXTRA_OECONF += "${MUTEX}" 72EXTRA_OECONF += "${MUTEX} STRIP=true"
79EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" 73
74AUTOTOOLS_SCRIPT_PATH = "${S}/dist"
80 75
81# Cancel the site stuff - it's set for db3 and destroys the 76# Cancel the site stuff - it's set for db3 and destroys the
82# configure. 77# configure.
83CONFIG_SITE = "" 78CONFIG_SITE = ""
84do_configure() { 79do_configure() {
85 gnu-configize --force ${S} 80 cd ${B}
86 export STRIP="true" 81 gnu-configize --force ${AUTOTOOLS_SCRIPT_PATH}
87 oe_runconf 82 oe_runconf
88} 83}
89 84
90do_compile_prepend() { 85do_compile_prepend() {
91 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' \ 86 # Stop libtool adding RPATHs
92 ${B}/libtool 87 sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/libtool
93} 88}
94 89
95do_install_append() { 90do_install_append() {
@@ -114,4 +109,3 @@ INSANE_SKIP_${PN} = "dev-so"
114INSANE_SKIP_${PN}-cxx = "dev-so" 109INSANE_SKIP_${PN}-cxx = "dev-so"
115 110
116BBCLASSEXTEND = "native nativesdk" 111BBCLASSEXTEND = "native nativesdk"
117