summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_4.2.52.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-01-15 21:14:46 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-27 21:53:24 +0000
commite77207ccdf15f34651a086099ed4816712e3656b (patch)
tree985194b5787bc01a278c1a68e8c347a03e5d609e /meta/recipes-support/db/db_4.2.52.bb
parent156405e57871d2339c99fc9b0ef58f0ee9b24e2e (diff)
downloadpoky-e77207ccdf15f34651a086099ed4816712e3656b.tar.gz
BerkleyDB: Uprev db from 4.2 to 5.1.19
The latest version of Berkley DB (5.1.19) is required by RPM. This version is backwards compatible with the 4.2 version that was enabled previously. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-support/db/db_4.2.52.bb')
-rw-r--r--meta/recipes-support/db/db_4.2.52.bb102
1 files changed, 0 insertions, 102 deletions
diff --git a/meta/recipes-support/db/db_4.2.52.bb b/meta/recipes-support/db/db_4.2.52.bb
deleted file mode 100644
index 1181bb05f9..0000000000
--- a/meta/recipes-support/db/db_4.2.52.bb
+++ /dev/null
@@ -1,102 +0,0 @@
1# Version 4 of the Berkeley DB from Sleepycat
2#
3# At present this package only installs the DB code
4# itself (shared libraries, .a in the dev package),
5# documentation and headers.
6#
7# The headers have the same names as those as v3
8# of the DB, only one version can be used *for dev*
9# at once - DB3 and DB4 can both be installed on the
10# same system at the same time if really necessary.
11SECTION = "libs"
12DESCRIPTION = "Berkeley DB v4."
13HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
14LICENSE = "BSD Sleepycat"
15VIRTUAL_NAME = "virtual/db"
16VIRTUAL_NAME_virtclass-native = "virtual/db-native"
17
18LIC_FILES_CHKSUM = "file://../LICENSE;md5=6b31228067ad1236eceaaaf187ad6d1e"
19
20CONFLICTS = "db3"
21CONFLICTS_virtclass-native = "db3-native"
22PR = "r8"
23
24SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz \
25 file://configure_fixes.patch;patch=1 "
26
27SRC_URI[md5sum] = "8b5cff6eb83972afdd8e0b821703c33c"
28SRC_URI[sha256sum] = "f4bddd8d1b4cde0daf5e13e3493ed62a25b736b0bf258e1d929e47bc6a82a28c"
29#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
30#TODO SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
31
32inherit autotools
33
34# Put virtual/db in any appropriate provider of a
35# relational database, use it as a dependency in
36# place of a specific db and use:
37#
38# PREFERRED_PROVIDER_virtual/db
39#
40# to select the correct db in the build (distro) .conf
41PROVIDES += "${VIRTUAL_NAME}"
42
43# bitbake isn't quite clever enough to deal with sleepycat,
44# the distribution sits in the expected directory, but all
45# the builds must occur from a sub-directory. The following
46# persuades bitbake to go to the right place
47S = "${WORKDIR}/db-${PV}/dist"
48B = "${WORKDIR}/db-${PV}/build_unix"
49
50# The executables go in a separate package - typically there
51# is no need to install these unless doing real database
52# management on the system.
53PACKAGES += " ${PN}-bin"
54
55# Package contents
56FILES_${PN} = "${libdir}/libdb-4*so*"
57FILES_${PN}-bin = "${bindir}/*"
58# The dev package has the .so link (as in db3) and the .a's -
59# it is therefore incompatible (cannot be installed at the
60# same time) as the db3 package
61FILES_${PN}-dev = "${includedir} ${libdir}/*"
62
63#configuration - set in local.conf to override
64DB4_CONFIG ?= " --disable-cryptography --disable-queue --disable-replication --disable-verify --enable-hash"
65EXTRA_OECONF = "${DB4_CONFIG}"
66
67# Override the MUTEX setting here, the POSIX library is
68# the default - "POSIX/pthreads/library".
69# Don't ignore the nice SWP instruction on the ARM:
70# These enable the ARM assembler mutex code, this won't
71# work with thumb compilation...
72ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
73MUTEX = ""
74MUTEX_arm = "${ARM_MUTEX}"
75MUTEX_armeb = "${ARM_MUTEX}"
76EXTRA_OECONF += "${MUTEX}"
77
78ARM_INSTRUCTION_SET = "arm"
79
80# Cancel the site stuff - it's set for db3 and destroys the
81# configure.
82CONFIG_SITE = ""
83do_configure() {
84 rm -f ${S}/config.sub
85 cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/config.sub
86 oe_runconf
87}
88
89do_install_append() {
90 # The docs end up in /usr/docs - not right.
91 if test -d "${D}/${prefix}/docs"
92 then
93 mkdir -p "${D}/${datadir}"
94 test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
95 mv "${D}/${prefix}/docs" "${D}/${docdir}"
96 fi
97}
98
99# The db package contains symlinks that trip up insane
100INSANE_SKIP_db = "1"
101
102BBCLASSEXTEND = "native nativesdk"