summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.75.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-04-09 16:27:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-18 11:37:25 +0100
commit218e1e3f4785c5548dd9042600b27438f8d6e4db (patch)
tree5344f1c14bc6ec3285c0c8944066778929c236b5 /meta/recipes-support/curl/curl_7.75.0.bb
parent3db91ef623024f0f03af362e2677baab5c4cbc4e (diff)
downloadpoky-218e1e3f4785c5548dd9042600b27438f8d6e4db.tar.gz
curl: upgrade 7.75.0 -> 7.76.0
(From OE-Core rev: c1dfe36c5641ce1ddc1424e56037e23fd927c058) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.75.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.75.0.bb89
1 files changed, 0 insertions, 89 deletions
diff --git a/meta/recipes-support/curl/curl_7.75.0.bb b/meta/recipes-support/curl/curl_7.75.0.bb
deleted file mode 100644
index 7666c7b608..0000000000
--- a/meta/recipes-support/curl/curl_7.75.0.bb
+++ /dev/null
@@ -1,89 +0,0 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2DESCRIPTION = "It uses URL syntax to transfer data to and from servers. \
3curl is a widely used because of its ability to be flexible and complete \
4complex tasks. For example, you can use curl for things like user authentication, \
5HTTP post, SSL connections, proxy support, FTP uploads, and more!"
6HOMEPAGE = "http://curl.haxx.se/"
7BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
8SECTION = "console/network"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=425f6fdc767cc067518eef9bbdf4ab7b"
11
12SRC_URI = "https://curl.haxx.se/download/curl-${PV}.tar.bz2 \
13 file://0001-replace-krb5-config-with-pkg-config.patch \
14"
15
16SRC_URI[sha256sum] = "50552d4501c178e4cc68baaecc487f466a3d6d19bbf4e50a01869effb316d026"
17
18# Curl has used many names over the years...
19CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl"
20
21inherit autotools pkgconfig binconfig multilib_header
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
24PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
25PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
26
27# 'ares' and 'threaded-resolver' are mutually exclusive
28PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
29PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
30PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
31PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
32PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
33PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
34PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
35PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
36PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
37PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
38PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
39PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
40PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
41PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
42PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
43PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
44PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
45PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
46PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
47PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
48PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
49PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
50PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
51PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
52PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
53PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
54PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares"
55PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
56PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
57
58EXTRA_OECONF = " \
59 --disable-libcurl-option \
60 --disable-ntlm-wb \
61 --enable-crypto-auth \
62 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
63 --without-libmetalink \
64 --without-libpsl \
65 --enable-debug \
66 --enable-optimize \
67 --disable-curldebug \
68"
69
70do_install_append_class-target() {
71 # cleanup buildpaths from curl-config
72 sed -i \
73 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
74 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
75 -e 's|${DEBUG_PREFIX_MAP}||g' \
76 ${D}${bindir}/curl-config
77}
78
79PACKAGES =+ "lib${BPN}"
80
81FILES_lib${BPN} = "${libdir}/lib*.so.*"
82RRECOMMENDS_lib${BPN} += "ca-certificates"
83
84FILES_${PN} += "${datadir}/zsh"
85
86inherit multilib_script
87MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
88
89BBCLASSEXTEND = "native nativesdk"