summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.61.0.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-11-19 06:41:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-20 10:32:16 +0000
commita00ca26adb557430b8fd5771820c47e1e2469e11 (patch)
treeab4c85a0adb469058da10f88e6791bbed18c0430 /meta/recipes-support/curl/curl_7.61.0.bb
parentaa24e1aaf84a2721fc58b43e458cb94f197f5677 (diff)
downloadpoky-a00ca26adb557430b8fd5771820c47e1e2469e11.tar.gz
curl: update to 7.62.0
Drop all CVE patches now included in update. For details see: https://curl.haxx.se/changes.html (From OE-Core rev: 43a802c2605cd2f6095a7738347338492eafe722) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.61.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.61.0.bb83
1 files changed, 0 insertions, 83 deletions
diff --git a/meta/recipes-support/curl/curl_7.61.0.bb b/meta/recipes-support/curl/curl_7.61.0.bb
deleted file mode 100644
index 56327a632b..0000000000
--- a/meta/recipes-support/curl/curl_7.61.0.bb
+++ /dev/null
@@ -1,83 +0,0 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ef889a37a5a874490ac7ce116396f29a"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10 file://CVE-2018-14618.patch \
11 file://CVE-2018-16839.patch \
12 file://CVE-2018-16840.patch \
13 file://CVE-2018-16842.patch \
14"
15
16SRC_URI[md5sum] = "31d0a9f48dc796a7db351898a1e5058a"
17SRC_URI[sha256sum] = "5f6f336921cf5b84de56afbd08dfb70adeef2303751ffb3e570c936c6d656c9c"
18
19CVE_PRODUCT = "curl libcurl"
20inherit autotools pkgconfig binconfig multilib_header
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
23PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
24PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
25
26# 'ares' and 'threaded-resolver' are mutually exclusive
27PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares"
28PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
29PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
30PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
31PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
32PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
33PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
36PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
37PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
38PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
39PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
40PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
41PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
42PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
43PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
44PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
45PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
46PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
47PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
48PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
49PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
50PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
51PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
52PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
53PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
54
55EXTRA_OECONF = " \
56 --disable-libcurl-option \
57 --disable-ntlm-wb \
58 --enable-crypto-auth \
59 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
60 --without-libmetalink \
61 --without-libpsl \
62"
63
64do_install_append_class-target() {
65 # cleanup buildpaths from curl-config
66 sed -i \
67 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
68 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
69 -e 's|${DEBUG_PREFIX_MAP}||g' \
70 ${D}${bindir}/curl-config
71}
72
73PACKAGES =+ "lib${BPN}"
74
75FILES_lib${BPN} = "${libdir}/lib*.so.*"
76RRECOMMENDS_lib${BPN} += "ca-certificates"
77
78FILES_${PN} += "${datadir}/zsh"
79
80inherit multilib_script
81MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
82
83BBCLASSEXTEND = "native nativesdk"