summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.47.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-06-12 10:21:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:34:59 +0100
commitdf25fcd664f659e2b7c5253ce91c80da005c362b (patch)
tree518d59fffa4c2567daecb5d61033ae51033f0824 /meta/recipes-support/curl/curl_7.47.1.bb
parentd665bfb04770501eb5747e0c9322821681076025 (diff)
downloadpoky-df25fcd664f659e2b7c5253ce91c80da005c362b.tar.gz
curl: upgrade to 7.49.1
(From OE-Core rev: 53761f4f2d4b8463bf9f996a87ee0dc61e21a2d0) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.47.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.47.1.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta/recipes-support/curl/curl_7.47.1.bb b/meta/recipes-support/curl/curl_7.47.1.bb
deleted file mode 100644
index b237b4ec9b..0000000000
--- a/meta/recipes-support/curl/curl_7.47.1.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
12# curl likes to set -g0 in CFLAGS, so we stop it
13# from mucking around with debug options
14#
15SRC_URI += " file://configure_ac.patch"
16
17SRC_URI[md5sum] = "9ea3123449439bbd960cd25cf98796fb"
18SRC_URI[sha256sum] = "ddc643ab9382e24bbe4747d43df189a0a6ce38fcb33df041b9cb0b3cd47ae98f"
19
20inherit autotools pkgconfig binconfig multilib_header
21
22PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls proxy zlib"
23PACKAGECONFIG_class-native = "ipv6 proxy ssl zlib"
24PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl zlib"
25
26PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
27PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
28PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
29PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
31PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
32PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
33PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
34PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
35PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
36PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
37PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
38PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
39PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
40PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
41PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
42PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
43PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
44PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
45PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
46
47EXTRA_OECONF = " \
48 --enable-crypto-auth \
49 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
50 --without-libmetalink \
51 --without-libpsl \
52 --without-nghttp2 \
53"
54
55do_install_append() {
56 oe_multilib_header curl/curlbuild.h
57}
58
59do_install_append_class-target() {
60 # cleanup buildpaths from curl-config
61 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
62}
63
64PACKAGES =+ "lib${BPN}"
65
66FILES_lib${BPN} = "${libdir}/lib*.so.*"
67RRECOMMENDS_lib${BPN} += "ca-certificates"
68
69FILES_${PN} += "${datadir}/zsh"
70
71BBCLASSEXTEND = "native nativesdk"