summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.47.1.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-08 14:49:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 12:27:46 +0000
commita0cc1c3e1f04b745d6533463a2930f6be433b527 (patch)
treea0ae8342207c859d12e320ef3dd03237b8856e54 /meta/recipes-support/curl/curl_7.47.1.bb
parenta0d3eb9f8c37c781cbb8eeeccb5e381939f12850 (diff)
downloadpoky-a0cc1c3e1f04b745d6533463a2930f6be433b527.tar.gz
curl: update 7.47.0 -> 7.47.1
Adjust LIC_FILES_CHKSUM beginline due to changes to the Copyright to acknowledge additional contributors. No change to the license text. (From OE-Core rev: 0ab2c3b105fe92efbc814a3985879996932878c6) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.47.1.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.47.1.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.47.1.bb b/meta/recipes-support/curl/curl_7.47.1.bb
new file mode 100644
index 0000000000..f2fa37ccf4
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.47.1.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://pkgconfig_fix.patch \
10 "
11
12# curl likes to set -g0 in CFLAGS, so we stop it
13# from mucking around with debug options
14#
15SRC_URI += " file://configure_ac.patch"
16
17SRC_URI[md5sum] = "9ea3123449439bbd960cd25cf98796fb"
18SRC_URI[sha256sum] = "ddc643ab9382e24bbe4747d43df189a0a6ce38fcb33df041b9cb0b3cd47ae98f"
19
20inherit autotools pkgconfig binconfig multilib_header
21
22PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls zlib"
23PACKAGECONFIG_class-native = "ipv6 ssl zlib"
24PACKAGECONFIG_class-nativesdk = "ipv6 ssl zlib"
25
26PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
27PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
28PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
29PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
30PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
31PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
32PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
33
34EXTRA_OECONF = "--without-libidn \
35 --enable-crypto-auth \
36 --disable-ldap \
37 --disable-ldaps \
38 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
39"
40# see https://lists.yoctoproject.org/pipermail/poky/2013-December/009435.html
41# We should ideally drop ac_cv_sizeof_off_t from site files but until then
42EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'ac_cv_sizeof_off_t=8', '', d)}"
43
44do_install_append() {
45 oe_multilib_header curl/curlbuild.h
46}
47
48do_install_append_class-target() {
49 # cleanup buildpaths from curl-config
50 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
51}
52
53PACKAGES =+ "lib${BPN}"
54
55FILES_lib${BPN} = "${libdir}/lib*.so.*"
56RRECOMMENDS_lib${BPN} += "ca-certificates"
57
58FILES_${PN} += "${datadir}/zsh"
59
60BBCLASSEXTEND = "native nativesdk"