summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.24.0.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-03-14 17:05:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-21 13:03:45 +0000
commitdba0656c1bfc4c2f95580a6803be991252f7668d (patch)
treedc3b4b3e312d471bd11993a532eff4eaabf52823 /meta/recipes-support/curl/curl_7.24.0.bb
parentb52bd42b63b3111b538dc05673cb51eafffdfa16 (diff)
downloadpoky-dba0656c1bfc4c2f95580a6803be991252f7668d.tar.gz
curl: upgrade to 7.24.0
(From OE-Core rev: ade51262effbf809c23bcf879ba43b7945e459ff) Signed-off-by: Shane Wang <shane.wang@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.24.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.24.0.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.24.0.bb b/meta/recipes-support/curl/curl_7.24.0.bb
new file mode 100644
index 0000000000..12e95c9bc0
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.24.0.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "Command line tool and library for client-side URL transfers."
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_virtclass-native = "zlib-native"
10DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
11PR = "r0"
12
13SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
14 file://noldlibpath.patch \
15 file://pkgconfig_fix.patch"
16
17SRC_URI[md5sum] = "f912221d75eb8d8fe08900eaf011b023"
18SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01812c16"
19
20inherit autotools pkgconfig binconfig
21
22EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
23 --without-ssl \
24 --without-libssh2 \
25 --with-random=/dev/urandom \
26 --without-libidn \
27 --enable-crypto-auth \
28 ${CURLGNUTLS} \
29 "
30
31CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../"
32CURLGNUTLS_virtclass-native = "--without-gnutls"
33CURLGNUTLS_virtclass-nativesdk = "--without-gnutls"
34
35do_configure_prepend() {
36 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
37}
38
39PACKAGES += "${PN}-certs libcurl libcurl-dev libcurl-doc"
40
41FILES_${PN} = "${bindir}/curl"
42
43FILES_${PN}-certs = "${datadir}/curl/curl-*"
44PACKAGE_ARCH_${PN}-certs = "all"
45
46FILES_${PN}-doc = "${mandir}/man1/curl.1"
47
48FILES_lib${BPN} = "${libdir}/lib*.so.*"
49RRECOMMENDS_lib${BPN} += "${PN}-certs"
50FILES_lib${BPN}-dev = "${includedir} \
51 ${libdir}/lib*.so \
52 ${libdir}/lib*.a \
53 ${libdir}/lib*.la \
54 ${libdir}/pkgconfig \
55 ${datadir}/aclocal \
56 ${bindir}/*-config"
57
58FILES_lib${BPN}-doc = "${mandir}/man3 \
59 ${mandir}/man1/curl-config.1"
60
61BBCLASSEXTEND = "native nativesdk"