summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.24.0.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-15 15:05:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-21 13:02:56 +0100
commit504e3733e51e7e2c1083a24546183817213786f8 (patch)
tree6a081e47f23abe358b474be64375ee756d5d963f /meta/recipes-support/curl/curl_7.24.0.bb
parente0a70547069fe7e8a2d6bdaffc985fb172d46c31 (diff)
downloadpoky-504e3733e51e7e2c1083a24546183817213786f8.tar.gz
curl: Use gnutls for target and openssl for native
Since gnutls is available on the target use it, but we do not build gnutls for the native side as it adds too many dependecies, so use openssl. (From OE-Core rev: 87610064a435f8b8b5694e4d6627e53b25d8f713) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.24.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.24.0.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta/recipes-support/curl/curl_7.24.0.bb b/meta/recipes-support/curl/curl_7.24.0.bb
index f9dce7de12..2c5369c014 100644
--- a/meta/recipes-support/curl/curl_7.24.0.bb
+++ b/meta/recipes-support/curl/curl_7.24.0.bb
@@ -5,10 +5,10 @@ SECTION = "console/network"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac" 6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7 7
8DEPENDS = "zlib gnutls openssl" 8DEPENDS = "zlib gnutls"
9DEPENDS_virtclass-native = "zlib-native openssl-native" 9DEPENDS_virtclass-native = "zlib-native openssl-native"
10DEPENDS_virtclass-nativesdk = "zlib-nativesdk openssl-nativesdk" 10DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
11PR = "r1" 11PR = "r2"
12 12
13SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ 13SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
14 file://noldlibpath.patch \ 14 file://noldlibpath.patch \
@@ -20,7 +20,6 @@ SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01
20inherit autotools pkgconfig binconfig 20inherit autotools pkgconfig binconfig
21 21
22EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \ 22EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
23 --with-ssl \
24 --without-libssh2 \ 23 --without-libssh2 \
25 --with-random=/dev/urandom \ 24 --with-random=/dev/urandom \
26 --without-libidn \ 25 --without-libidn \
@@ -28,9 +27,9 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
28 ${CURLGNUTLS} \ 27 ${CURLGNUTLS} \
29 " 28 "
30 29
31CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../" 30CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
32CURLGNUTLS_virtclass-native = "--without-gnutls" 31CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"
33CURLGNUTLS_virtclass-nativesdk = "--without-gnutls" 32CURLGNUTLS_virtclass-nativesdk = "--without-gnutls --without-ssl"
34 33
35do_configure_prepend() { 34do_configure_prepend() {
36 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac 35 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac